summaryrefslogtreecommitdiffstats
path: root/testing/shorewall6/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-10-18 18:43:20 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-18 18:47:12 +0000
commit31244fed0df5f208ba5501ed7c0fa888d35c989b (patch)
treed905d3cad623b8fa3655a2a8e40ef0f4988fb403 /testing/shorewall6/APKBUILD
parent20810d39856c166f28ca1ee172374e30b85499b0 (diff)
downloadaports-31244fed0df5f208ba5501ed7c0fa888d35c989b.tar.bz2
aports-31244fed0df5f208ba5501ed7c0fa888d35c989b.tar.xz
testing/shorewall6: new aport
ref #1154
Diffstat (limited to 'testing/shorewall6/APKBUILD')
-rw-r--r--testing/shorewall6/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/testing/shorewall6/APKBUILD b/testing/shorewall6/APKBUILD
new file mode 100644
index 000000000..c36df0654
--- /dev/null
+++ b/testing/shorewall6/APKBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=shorewall6
+pkgver=4.5.21
+pkgrel=0
+pkgdesc="Files for the IPV6 Shorewall Firewall"
+url="http://www.shorewall.net/"
+arch="noarch"
+license="GPL-2"
+depends="shorewall-core perl iptables iproute2"
+# coreutils for install -T
+makedepends="coreutils bash"
+replaces=""
+subpackages="$pkgname-doc"
+source="http://www1.shorewall.net/pub/shorewall/${pkgver%.*}/shorewall-$pkgver/$pkgname-$pkgver.tar.bz2
+ shorewall6.initd
+ "
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure MANDIR=/usr/share/man SBINDIR=/usr/sbin || return 1
+}
+
+package() {
+ cd "$_builddir"
+ DESTDIR="$pkgdir" ./install.sh || return 1
+ rm -f "$pkgdir"/etc/init.d/shorewall6 || return 1
+ install -m755 "$srcdir"/shorewall6.initd "$pkgdir"/etc/init.d/shorewall6
+}
+
+md5sums="aaa1d6e1adb00acace63993ab6be6d37 shorewall6-4.5.21.tar.bz2
+41c4981e5230a2abeeec749f7f5bf727 shorewall6.initd"
+sha256sums="2c23a00a2ac441bcaa7c7b6b188079931f98b0444bbba137a400e81bedcd28dc shorewall6-4.5.21.tar.bz2
+f4de42b7a47cd5f4e5a86af84d80579c49f5c0e817c20e2f3919ef0f4af015ea shorewall6.initd"
+sha512sums="f95dd9cbf44378af0ce9b25f95fd1fd8e277fa38955bebd94490369bb891785744e401c62c182236a047ab55f70f571f8a4617d743ba7333a71810dda91e81f4 shorewall6-4.5.21.tar.bz2
+3d4787cf5af0f32c1b033f89e3a1b390382b64fb70a492ff4dfe78499ceff8ec9c85dccf394edfb67ed512f85d954bba46bfe3e1ea762921bb0d65705f7c3695 shorewall6.initd"