summaryrefslogtreecommitdiffstats
path: root/testing/sipvicious
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2012-05-19 10:35:13 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2012-05-20 16:57:44 +0000
commit2bd675a6706a27bc8098dfd924e34e7688508934 (patch)
treef5c52a2a9acc69dd6cc1d63074245a75a9732899 /testing/sipvicious
parent78127647072f87bf44715429bbea77946d700a07 (diff)
downloadaports-2bd675a6706a27bc8098dfd924e34e7688508934.tar.bz2
aports-2bd675a6706a27bc8098dfd924e34e7688508934.tar.xz
testing/sipvicious: new aport
SIPVicious suite is a set of tools that can be used to audit SIP based VoIP systems. It currently consists of four tools: - svmap - this is a sip scanner. Lists SIP devices found on an IP range - svwar - identifies active extensions on a PBX - svcrack - an online password cracker for SIP PBX - svreport - manages sessions and exports reports to various formats - svcrash - attempts to stop unauthorized svwar and svcrack scans http://code.google.com/p/sipvicious/
Diffstat (limited to 'testing/sipvicious')
-rw-r--r--testing/sipvicious/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/sipvicious/APKBUILD b/testing/sipvicious/APKBUILD
new file mode 100644
index 000000000..87b08988a
--- /dev/null
+++ b/testing/sipvicious/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=sipvicious
+pkgver=0.2.7
+pkgrel=0
+pkgdesc="Tools for auditing SIP based VoIP systems"
+url="http://code.google.com/p/sipvicious/"
+arch="noarch"
+license="GPL2"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages=""
+source="http://sipvicious.googlecode.com/files/$pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ return 0
+}
+
+build() {
+ cd "$_builddir"
+ return 0
+}
+
+package() {
+ cd "$_builddir"
+ for file in *.py; do
+ install -Dm 0755 $file "$pkgdir"/usr/bin/$file || return 1
+ done
+}
+
+md5sums="a30c9865d3eac5518d5fd9ced25424f1 sipvicious-0.2.7.tar.gz"