summaryrefslogtreecommitdiffstats
path: root/testing/slony1
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-08-15 08:57:32 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-08-15 09:04:31 +0000
commit11233ac93b5354d5274c88f500d702426282ae16 (patch)
treeda259bc3a54e47724b3070a6115b86e1d9be7bd8 /testing/slony1
parent2fe619084f6fa2593014b585f4009528afeb463c (diff)
downloadaports-11233ac93b5354d5274c88f500d702426282ae16.tar.bz2
aports-11233ac93b5354d5274c88f500d702426282ae16.tar.xz
testing/slony1: new aport
A master to multiple slaves replication system for PostgreSQL http://slony.info/
Diffstat (limited to 'testing/slony1')
-rw-r--r--testing/slony1/APKBUILD52
-rw-r--r--testing/slony1/slony1.confd12
-rwxr-xr-xtesting/slony1/slony1.initd37
3 files changed, 101 insertions, 0 deletions
diff --git a/testing/slony1/APKBUILD b/testing/slony1/APKBUILD
new file mode 100644
index 000000000..b45d3b6af
--- /dev/null
+++ b/testing/slony1/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=slony1
+pkgver=2.0.7
+pkgrel=0
+pkgdesc="A master to multiple slaves replication system for PostgreSQL"
+url="http://slony.info/"
+arch="all"
+license="BSD"
+depends=""
+makedepends="postgresql-dev"
+install=""
+subpackages=""
+source="http://main.slony.info/downloads/2.0/source/slony1-$pkgver.tar.bz2
+ slony1.initd
+ slony1.confd"
+
+_builddir="$srcdir"/slony1-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+ install -Dm755 "$srcdir"/slony1.initd "$pkgdir"/etc/init.d/slony1 \
+ || return 1
+ install -Dm644 "$srcdir"/slony1.confd "$pkgdir"/etc/conf.d/slony1 \
+ || return 1
+}
+
+md5sums="e8aadfa9c1115f5ce43079381a4b51b5 slony1-2.0.7.tar.bz2
+a4d6b16ff6f23fbb578af35472f1ec97 slony1.initd
+27fe1a24fcab45c0e3ad4dd3e53287cf slony1.confd"
diff --git a/testing/slony1/slony1.confd b/testing/slony1/slony1.confd
new file mode 100644
index 000000000..07822329a
--- /dev/null
+++ b/testing/slony1/slony1.confd
@@ -0,0 +1,12 @@
+# /etc/conf.d/slony1:
+# $Header: /var/cvsroot/gentoo-x86/dev-db/slony1/files/slony1.conf,v 1.2 2007/03/07 23:18:21 nakano Exp $
+
+# Configuration file for /etc/init.d/slony1
+
+USER=postgres
+CLUSTER=your_cluster_name
+DBUSER=postgres
+DBNAME=your_database_name
+DBHOST=localhost
+LOGFILE=/var/lib/postgresql/data/slony1.log
+LOGLEVEL=1 # 1(minimum)..4(maximum)
diff --git a/testing/slony1/slony1.initd b/testing/slony1/slony1.initd
new file mode 100755
index 000000000..4f1469dc6
--- /dev/null
+++ b/testing/slony1/slony1.initd
@@ -0,0 +1,37 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/slony1/files/slony1.init,v 1.2 2007/03/07 23:18:21 nakano Exp $
+
+depend() {
+ need postgresql
+}
+
+start() {
+ ebegin "Starting slony1"
+ /usr/bin/slon -p /var/run/slony1.pid -d $LOGLEVEL $CLUSTER "dbname=$DBNAME user=$DBUSER host=$DBHOST" >> $LOGFILE 2>&1 &
+
+ while :
+ do
+ cnt=$(($cnt + 1))
+ if [ -f "/var/run/slony1.pid" ]; then
+ ret=0
+ break
+ fi
+
+ if [ $cnt -eq 30 ]; then
+ eerror "Please see log file: $LOGFILE"
+ ret=1
+ break
+ fi
+ sleep 1
+ done
+ eend $ret
+}
+
+stop() {
+ ebegin "Stopping slony1"
+ kill `cat /var/run/slony1.pid`
+ eend $?
+}
+