summaryrefslogtreecommitdiffstats
path: root/testing/spl-grsec
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-08-26 15:22:19 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2013-08-26 15:33:05 +0200
commit61b1e2e368f649604e720dba079e0b33520d0ec6 (patch)
tree6af590112f4ab60453272bda1e493f3d45e7e48e /testing/spl-grsec
parent58d7aed4d256103541de59788bb46b65523ba260 (diff)
downloadaports-61b1e2e368f649604e720dba079e0b33520d0ec6.tar.bz2
aports-61b1e2e368f649604e720dba079e0b33520d0ec6.tar.xz
testing/spl-grsec: rebuild against kernel 3.10.9-r0
Diffstat (limited to 'testing/spl-grsec')
-rw-r--r--testing/spl-grsec/APKBUILD17
-rw-r--r--testing/spl-grsec/constify.patch49
2 files changed, 6 insertions, 60 deletions
diff --git a/testing/spl-grsec/APKBUILD b/testing/spl-grsec/APKBUILD
index 78aae5b82..85ec5dc30 100644
--- a/testing/spl-grsec/APKBUILD
+++ b/testing/spl-grsec/APKBUILD
@@ -8,7 +8,7 @@ _kpkg=linux-$_flavor
_kver=3.10.9
_kpkgrel=0
-_realver=0.6.1
+_realver=0.6.2
_mypkgrel=0
# source the kernel version
@@ -26,16 +26,14 @@ pkgver=$_kver
pkgrel=$(($_kpkgrel + $_mypkgrel))
pkgdesc="Solaris Porting Layer"
url="http://zfsonlinux.org"
-#arch="x86 x86_64"
-arch=
+arch="x86 x86_64"
license="GPL"
depends=""
depends_dev="linux-grsec-dev=$_kernelver"
makedepends="$depends_dev perl automake autoconf libtool"
install=""
subpackages="$pkgname-dev $pkgname-utils"
-source="http://archive.zfsonlinux.org/downloads/zfsonlinux/spl/spl-$_realver.tar.gz
- constify.patch"
+source="http://archive.zfsonlinux.org/downloads/zfsonlinux/spl/spl-$_realver.tar.gz"
_builddir="$srcdir"/spl-$_realver
prepare() {
@@ -84,9 +82,6 @@ utils() {
"$pkgdir"/lib/ || return 1
}
-md5sums="0f58806d9fd9cab900181b59b21bae50 spl-0.6.1.tar.gz
-19c02cd34e2b36cf3ae9c71ee9c443fe constify.patch"
-sha256sums="6baa3e56a945a508273dd47153e43610659fb6c3dfbe58d96a772e009855d1ae spl-0.6.1.tar.gz
-b0b856a073f7b55b1bb49be927fac7900d28cea8208aca2c02bac529c7316cf7 constify.patch"
-sha512sums="a992c5cdccf6883da1dbe5bfde0bdc639cc6e4c1364b7b94d0ac0b9ddcb8db6af9138fe0d67112adc368dd4055dce17e8fa22d7cbc679651ecb18fd9b4439835 spl-0.6.1.tar.gz
-6aab408f2e5dcca0bcaa0f4713d93d49068a11fa35d9f2f7a15bb0eef6c1eb8613c89769bb3b054ca70be359e109fef81ae1cd3166920c4df183363ee5309af3 constify.patch"
+md5sums="f00535bf89a7fde0e08f44a14a1f1e03 spl-0.6.2.tar.gz"
+sha256sums="3c577c7055d6c73179726b9c8a7fd48f9122be0b345c50cd54732e801165daa4 spl-0.6.2.tar.gz"
+sha512sums="a79bc730f80e08e917249a0872d1215fd8507c9fcf42a63d6abf320befadea94973df6530c110701f554005309dbbcefb4b6b17a3da38e8a70c8e1b186bae6a6 spl-0.6.2.tar.gz"
diff --git a/testing/spl-grsec/constify.patch b/testing/spl-grsec/constify.patch
deleted file mode 100644
index 92d0bf568..000000000
--- a/testing/spl-grsec/constify.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-diff --git a/module/spl/spl-proc.c b/module/spl/spl-proc.c
-index cd4fa1b..1ba7d2f 100644
---- a/module/spl/spl-proc.c
-+++ b/module/spl/spl-proc.c
-@@ -323,7 +323,7 @@ SPL_PROC_HANDLER(proc_force_bug)
- SPL_PROC_HANDLER(proc_console_max_delay_cs)
- {
- int rc, max_delay_cs;
-- struct ctl_table dummy = *table;
-+ ctl_table_no_const dummy = *table;
- long d;
- SENTRY;
-
-@@ -355,7 +355,7 @@ SPL_PROC_HANDLER(proc_console_max_delay_cs)
- SPL_PROC_HANDLER(proc_console_min_delay_cs)
- {
- int rc, min_delay_cs;
-- struct ctl_table dummy = *table;
-+ ctl_table_no_const dummy = *table;
- long d;
- SENTRY;
-
-@@ -387,7 +387,7 @@ SPL_PROC_HANDLER(proc_console_min_delay_cs)
- SPL_PROC_HANDLER(proc_console_backoff)
- {
- int rc, backoff;
-- struct ctl_table dummy = *table;
-+ ctl_table_no_const dummy = *table;
- SENTRY;
-
- dummy.data = &backoff;
-@@ -417,7 +417,7 @@ SPL_PROC_HANDLER(proc_domemused)
- {
- int rc = 0;
- unsigned long min = 0, max = ~0, val;
-- struct ctl_table dummy = *table;
-+ ctl_table_no_const dummy = *table;
- SENTRY;
-
- dummy.data = &val;
-@@ -444,7 +444,7 @@ SPL_PROC_HANDLER(proc_doslab)
- {
- int rc = 0;
- unsigned long min = 0, max = ~0, val = 0, mask;
-- struct ctl_table dummy = *table;
-+ ctl_table_no_const dummy = *table;
- spl_kmem_cache_t *skc;
- SENTRY;
-