summaryrefslogtreecommitdiffstats
path: root/testing/task
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-08-28 12:24:12 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-08-28 12:24:15 +0000
commitccb96e9ddc75695902c8306821504da0e59ce54f (patch)
tree06e1b66221f920dd56415aca9a3325a5a74cefbd /testing/task
parent65771cabd455123fc6fee135fe2e9c0346e91295 (diff)
downloadaports-ccb96e9ddc75695902c8306821504da0e59ce54f.tar.bz2
aports-ccb96e9ddc75695902c8306821504da0e59ce54f.tar.xz
testing/task: new aport
A command-line to do list manager http://taskwarrior.org ref #2227
Diffstat (limited to 'testing/task')
-rw-r--r--testing/task/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/testing/task/APKBUILD b/testing/task/APKBUILD
new file mode 100644
index 000000000..adc6d2103
--- /dev/null
+++ b/testing/task/APKBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=task
+pkgver=2.2.0
+pkgrel=0
+pkgdesc="A command-line to do list manager"
+url="http://taskwarrior.org"
+arch="all"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends="$depends_dev cmake util-linux-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://taskwarrior.org/download/task-$pkgver.tar.gz"
+
+_builddir="$srcdir"/task-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ cmake . \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make install DESTDIR="$pkgdir"
+}
+
+md5sums="eb5af01b51b90e01b574464a5d11d4e9 task-2.2.0.tar.gz"
+sha256sums="39e25dd285e6bc8474337a5868cb2ec55675978fa1f08c802e6da58b4181ee14 task-2.2.0.tar.gz"
+sha512sums="16ff1ccd037d62fc99ea0a31647714d3ccf8a90948b67d845d55e08e4bf49bb6a7f69f7464f485093abeff0672f17dc5f6d4efd96d2e447316975d185082f862 task-2.2.0.tar.gz"