summaryrefslogtreecommitdiffstats
path: root/testing/telegram-cli
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2014-01-27 13:31:40 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2014-01-27 13:31:51 +0000
commite8a7e94f5dd90fc180a019d925fe09baa99039d6 (patch)
treed4a8976eb3f97160b93bb92c6d04c4bff5a4831c /testing/telegram-cli
parent4027eb8f7da57af4d3353241a2f86807ee3b77ee (diff)
downloadaports-e8a7e94f5dd90fc180a019d925fe09baa99039d6.tar.bz2
aports-e8a7e94f5dd90fc180a019d925fe09baa99039d6.tar.xz
testing/telegram-cli: add public key
Diffstat (limited to 'testing/telegram-cli')
-rw-r--r--testing/telegram-cli/0001-change-public-key-location.patch25
-rw-r--r--testing/telegram-cli/APKBUILD28
2 files changed, 42 insertions, 11 deletions
diff --git a/testing/telegram-cli/0001-change-public-key-location.patch b/testing/telegram-cli/0001-change-public-key-location.patch
new file mode 100644
index 000000000..5569879e6
--- /dev/null
+++ b/testing/telegram-cli/0001-change-public-key-location.patch
@@ -0,0 +1,25 @@
+From 193dbf82809b5ed5db8f8c37c315592d529ee37a Mon Sep 17 00:00:00 2001
+From: Carlo Landmeter <clandmeter@gmail.com>
+Date: Mon, 27 Jan 2014 13:26:44 +0000
+Subject: [PATCH] change public key location
+
+---
+ mtproto-client.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/mtproto-client.c b/mtproto-client.c
+index 06ddfdc..4279512 100644
+--- a/mtproto-client.c
++++ b/mtproto-client.c
+@@ -129,7 +129,7 @@ int Response_len;
+ *
+ */
+
+-char *rsa_public_key_name = "tg.pub";
++char *rsa_public_key_name = "/usr/share/telegram/tg.pub";
+ RSA *pubKey;
+ long long pk_fingerprint;
+
+--
+1.8.5.3
+
diff --git a/testing/telegram-cli/APKBUILD b/testing/telegram-cli/APKBUILD
index 93f6d85c7..36753e5cc 100644
--- a/testing/telegram-cli/APKBUILD
+++ b/testing/telegram-cli/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
pkgname=telegram-cli
-pkgver=0.01_git20140127
-verbase=0.01
+pkgver=0.1_git20140127
+verbase=0.1
pkgrel=0
pkgdesc="Command line telegram client"
url="https://github.com/vysheng/tg"
@@ -12,7 +12,8 @@ depends_dev="readline-dev openssl-dev libconfig-dev"
makedepends="$depends_dev"
subpackages=""
source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.gz
- 0001-uclibc-does-not-provide-aio.h.patch"
+ 0001-uclibc-does-not-provide-aio.h.patch
+ 0001-change-public-key-location.patch"
giturl="git://github.com/vysheng/tg.git"
disturl="dev.alpinelinux.org:/archive/$pkgname/"
@@ -45,13 +46,18 @@ build() {
package() {
cd "$_builddir"
- mkdir -p "$pkgdir"/usr/bin || return 1
- cp telegram "$pkgdir"/usr/bin
+ install -D telegram \
+ "$pkgdir"/usr/bin/telegram || return 1
+ install -D tg.pub \
+ "$pkgdir"/usr/share/telegram/tg.pub || return 1
}
-md5sums="4753891325f51690d9fabab8e009b6ff telegram-cli-0.01_git20140127.tar.gz
-ed21dd0f9056fe3a8132894ccf943844 0001-uclibc-does-not-provide-aio.h.patch"
-sha256sums="e06b0f09d2dcaaefde83abeb67aae3d16bee044eb93a6a725c04bf6d04570d2c telegram-cli-0.01_git20140127.tar.gz
-5a92614b40c50fcd5b5601c33d87edba421086eb777663bc6c43d18734b4cfea 0001-uclibc-does-not-provide-aio.h.patch"
-sha512sums="e10112884e458eb123f65ffec8267c5f02f5ab6e78ee05024b2c5923c8e6ddb702ba8be9993d92af6a55c3e1ac957099af02fc6e1f8a157ea9fe1668b9036569 telegram-cli-0.01_git20140127.tar.gz
-46725ec1d6255ddb359e8e33a73510461264451689f7bcc14233e3730a6cae26073b0629af18443c1ad6e7140748e75293349b97ac8d8cec21b0c10541a62333 0001-uclibc-does-not-provide-aio.h.patch"
+md5sums="fc460c51f541532fa6d0a103aa41dd29 telegram-cli-0.1_git20140127.tar.gz
+ed21dd0f9056fe3a8132894ccf943844 0001-uclibc-does-not-provide-aio.h.patch
+f5bd613201b14ac0d212a82ee4ef6dbb 0001-change-public-key-location.patch"
+sha256sums="d47f47d438443b36397ecd83a6334ada2922741558b91c0075ee9358083c8b7a telegram-cli-0.1_git20140127.tar.gz
+5a92614b40c50fcd5b5601c33d87edba421086eb777663bc6c43d18734b4cfea 0001-uclibc-does-not-provide-aio.h.patch
+276ea7237e12f40f5e65d083cf8b64876aa8153adf7cbaf594a37daea71c304c 0001-change-public-key-location.patch"
+sha512sums="5a0ae0c6f8f18d7b4d1b3191044e16793a5816ebb9d1a8fc423bdbf2e0e7867819021c82dab5775c1ec2e1a86dfdb729f603a22f012ce7b8e9e51976ec11f8fb telegram-cli-0.1_git20140127.tar.gz
+46725ec1d6255ddb359e8e33a73510461264451689f7bcc14233e3730a6cae26073b0629af18443c1ad6e7140748e75293349b97ac8d8cec21b0c10541a62333 0001-uclibc-does-not-provide-aio.h.patch
+58643338812189681ca96882325050187e6a6309937fcc0af17a630d1affcbfe0d14205fd0e80dc65a51016b6ebb916fec31d275857efed8a6a2a54268d45b31 0001-change-public-key-location.patch"