summaryrefslogtreecommitdiffstats
path: root/testing/tvheadend-git
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-06-13 12:01:15 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-06-13 12:01:15 +0000
commit54ec7844771602863802e05fdc837c452d74917c (patch)
tree54742e693f72682b9710826c740fe5c19223c1ef /testing/tvheadend-git
parent3a8de4c9a71a2a1ed54ca95a980e857c37616985 (diff)
downloadaports-54ec7844771602863802e05fdc837c452d74917c.tar.bz2
aports-54ec7844771602863802e05fdc837c452d74917c.tar.xz
testing/tvheadend-git: rename dir
Diffstat (limited to 'testing/tvheadend-git')
-rw-r--r--testing/tvheadend-git/APKBUILD45
-rw-r--r--testing/tvheadend-git/tvheadend-git.confd2
-rw-r--r--testing/tvheadend-git/tvheadend-git.initd18
-rw-r--r--testing/tvheadend-git/tvheadend-git.post-deinstall4
-rw-r--r--testing/tvheadend-git/tvheadend-git.pre-install5
5 files changed, 74 insertions, 0 deletions
diff --git a/testing/tvheadend-git/APKBUILD b/testing/tvheadend-git/APKBUILD
new file mode 100644
index 000000000..f800ab0d9
--- /dev/null
+++ b/testing/tvheadend-git/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+pkgname=tvheadend-git
+_pkgname=andoma-tvheadend-bccec43
+pkgver=2.99
+pkgrel=0
+pkgdesc="TV Streaming server for linux"
+url="http://www.lonelycoder.com/hts/tvheadend_overview.html"
+arch="all"
+license="GPL3"
+depends=""
+depends_dev="openssl-dev avahi-dev wget bash findutils"
+makedepends="$depends_dev"
+install="$pkgname.pre-install $pkgname.post-deinstall"
+subpackages=""
+source="saveas-https://github.com/andoma/tvheadend/tarball/master/$pkgname-$pkgver.tar.gz
+tvheadend-git.initd
+tvheadend-git.confd
+"
+_builddir="$srcdir"/$_pkgname
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr --release
+ make || return 1
+}
+package() {
+ cd "$_builddir"
+ sed -i 's/\-T//g' support/posix.mk
+ make DESTDIR="$pkgdir" install || return 1
+ install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname || return 1
+ install -m755 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname || return 1
+}
+
+md5sums="96fa898ae84aefbc25e12067eb8a93c1 tvheadend-git-2.99.tar.gz
+4d6324b1b87890faf846ad95c2f3483c tvheadend-git.initd
+74749f3527418ddfd5671d5d5ad4dca4 tvheadend-git.confd"
diff --git a/testing/tvheadend-git/tvheadend-git.confd b/testing/tvheadend-git/tvheadend-git.confd
new file mode 100644
index 000000000..a912932ae
--- /dev/null
+++ b/testing/tvheadend-git/tvheadend-git.confd
@@ -0,0 +1,2 @@
+TVHBIN="/usr/bin/tvheadend"
+TVHUSER="tvheadend"
diff --git a/testing/tvheadend-git/tvheadend-git.initd b/testing/tvheadend-git/tvheadend-git.initd
new file mode 100644
index 000000000..6a50b9f3f
--- /dev/null
+++ b/testing/tvheadend-git/tvheadend-git.initd
@@ -0,0 +1,18 @@
+#!/sbin/runscript
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting tvheadend"
+ start-stop-daemon --start \
+ --user ${TVHUSER} \
+ --exec ${TVHBIN} -- -C -f
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping tvheadend"
+ start-stop-daemon --stop --quiet --name tvheadend --signal 2
+ eend $?
+}
diff --git a/testing/tvheadend-git/tvheadend-git.post-deinstall b/testing/tvheadend-git/tvheadend-git.post-deinstall
new file mode 100644
index 000000000..b80984d6f
--- /dev/null
+++ b/testing/tvheadend-git/tvheadend-git.post-deinstall
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+deluser hts 2>/dev/null
+exit 0
diff --git a/testing/tvheadend-git/tvheadend-git.pre-install b/testing/tvheadend-git/tvheadend-git.pre-install
new file mode 100644
index 000000000..73f865ca4
--- /dev/null
+++ b/testing/tvheadend-git/tvheadend-git.pre-install
@@ -0,0 +1,5 @@
+#!/bin/sh
+groupadd tvheadend 2>/dev/null
+adduser -H -h /home/tvheadend -g tvheadend -D -s /bin/false tvheadend 2>/dev/null
+gpasswd -a tvheadend video 2>/dev/null
+exit 0