summaryrefslogtreecommitdiffstats
path: root/testing/uptimed
diff options
context:
space:
mode:
authorKiyoshi Aman <kiyoshi.aman@gmail.com>2011-01-23 19:07:25 -0500
committerKiyoshi Aman <kiyoshi.aman@gmail.com>2011-02-03 19:03:13 -0500
commit17aadbadc72b8335f7bf68597d2fbabc50d1e998 (patch)
tree21794d20ad791f5e0c64ab9e2de0b7a1ca2f695c /testing/uptimed
parent288629eaa414c3f0ff0959457ff5b214c98e1423 (diff)
downloadaports-17aadbadc72b8335f7bf68597d2fbabc50d1e998.tar.bz2
aports-17aadbadc72b8335f7bf68597d2fbabc50d1e998.tar.xz
testing/uptimed: new aport (needs work)
Diffstat (limited to 'testing/uptimed')
-rw-r--r--testing/uptimed/APKBUILD51
-rw-r--r--testing/uptimed/uptimed.confd12
-rw-r--r--testing/uptimed/uptimed.initd30
3 files changed, 93 insertions, 0 deletions
diff --git a/testing/uptimed/APKBUILD b/testing/uptimed/APKBUILD
new file mode 100644
index 000000000..c9142f46e
--- /dev/null
+++ b/testing/uptimed/APKBUILD
@@ -0,0 +1,51 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+pkgname=uptimed
+pkgver=0.3.16
+pkgrel=0
+pkgdesc="Utility for keeping track of uptime records"
+url="http://podgorny.cz/moin/Uptimed"
+arch="all"
+license="GPL"
+depends=
+makedepends="automake autoconf libtool"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="
+ http://podgorny.cz/uptimed/releases/$pkgname-$pkgver.tar.bz2
+ uptimed.initd
+ uptimed.confd
+ "
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ autoreconf
+ libtoolize
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+
+ install -m755 -D "$srcdir"/$pkgname.initd \
+ "$pkgdir"/etc/init.d/$pkgname || return 1
+ install -m644 -D "$srcdir"/$pkgname.confd \
+ "$pkgdir"/etc/conf.d/$pkgname || return 1
+}
+
+md5sums="f87ec2cc39039239004afa542cf99c59 uptimed-0.3.16.tar.bz2
+b9776cc0245666122dc9d745fcba3245 uptimed.initd
+f648724df795b81afdcc3484258cfd25 uptimed.confd"
diff --git a/testing/uptimed/uptimed.confd b/testing/uptimed/uptimed.confd
new file mode 100644
index 000000000..dcc4741cf
--- /dev/null
+++ b/testing/uptimed/uptimed.confd
@@ -0,0 +1,12 @@
+# Sample conf.d file for alpine linux
+#
+# uptimed opts:
+# -b create bootid and exit [ignored on FreeBSD]
+# -f run in foreground [don't fork]
+# -e EMAIL send mail to EMAIL at milestones/records
+# -i INTERVAL use INTERVAL seconds for loop
+# -m COUNT log a maximum of COUNT entries
+# -t TIMESPEC minimum uptime to be considered a record
+# -p FILE write PID to FILE
+
+opts=""
diff --git a/testing/uptimed/uptimed.initd b/testing/uptimed/uptimed.initd
new file mode 100644
index 000000000..ec6493f8f
--- /dev/null
+++ b/testing/uptimed/uptimed.initd
@@ -0,0 +1,30 @@
+#!/sbin/runscript
+
+# Sample init.d file for alpine linux.
+
+name=uptimed
+daemon=/usr/sbin/$name
+source /etc/conf.d/$name
+
+depend() {
+ need net
+ after firewall
+}
+
+start() {
+ ebegin "Starting ${name}"
+ start-stop-daemon --start --quiet \
+ --pidfile /var/run/${name}.pid \
+ --chuid nobody:nobody \
+ --exec ${daemon} -- ${opts}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${name}"
+ start-stop-daemon --stop --quiet \
+ --pidfile /var/run/$name.pid \
+ --exec ${daemon}
+ eend $?
+}
+