summaryrefslogtreecommitdiffstats
path: root/testing/vim-sleuth
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-06-18 06:47:30 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-06-18 12:24:19 +0000
commitedc3a2b2750975af7ab9550726659cc5055265ca (patch)
tree44132b959842b6e78d407db424bb8b76abe72a82 /testing/vim-sleuth
parentaeafa67672c4e4ae56c16c9156bac8788fc3ac29 (diff)
downloadaports-edc3a2b2750975af7ab9550726659cc5055265ca.tar.bz2
aports-edc3a2b2750975af7ab9550726659cc5055265ca.tar.xz
testing/vim-sleuth: new aport
vim: Heuristically set buffer options https://github.com/tpope/vim-sleuth
Diffstat (limited to 'testing/vim-sleuth')
-rw-r--r--testing/vim-sleuth/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/vim-sleuth/APKBUILD b/testing/vim-sleuth/APKBUILD
new file mode 100644
index 000000000..d36285b33
--- /dev/null
+++ b/testing/vim-sleuth/APKBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=vim-sleuth
+pkgver=1.1
+pkgrel=0
+pkgdesc="vim: Heuristically set buffer options"
+url="https://github.com/tpope/vim-sleuth"
+arch="noarch"
+license="Vim"
+depends="vim"
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages=""
+source="$pkgname-$pkgver.tar.gz::https://github.com/tpope/vim-sleuth/archive/v$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ return 0
+}
+
+package() {
+ cd "$_builddir"
+ mkdir -p "$pkgdir"/usr/share/vim/vim73
+ cp -r plugin doc "$pkgdir"/usr/share/vim/vim73/
+}
+
+md5sums="beb1ac4938b87fa858d52ca28590393c vim-sleuth-1.1.tar.gz"
+sha256sums="18620f3b09a824e35983730ec82d2fddbc838452fcfedd9c252485727875c8a4 vim-sleuth-1.1.tar.gz"
+sha512sums="216af1e0d1307b4a7292c5567451876a94de52a4f22c65f892e4fd674067347afc1c86377b5b57eb94ad9c37b3be9e300f730f15bc1cdba3ccf66ade7db8bd13 vim-sleuth-1.1.tar.gz"