summaryrefslogtreecommitdiffstats
path: root/testing/voiphopper
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2012-04-11 19:10:19 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2012-05-17 13:48:54 +0000
commit343b57eb1a60b9e2bbc6404e0b05dbdcb8e3fc9f (patch)
tree49a2ac58e87745f5e386eb34572b84d3606bb318 /testing/voiphopper
parente458e286b9028cbc1d13f98fa56987a9ef640001 (diff)
downloadaports-343b57eb1a60b9e2bbc6404e0b05dbdcb8e3fc9f.tar.bz2
aports-343b57eb1a60b9e2bbc6404e0b05dbdcb8e3fc9f.tar.xz
testing/voiphopper: new aport
VoIP Hopper is a VoIP infrastructure security testing tool but also a tool that can be used to test the (in)security of VLANs. http://voiphopper.sourceforge.net
Diffstat (limited to 'testing/voiphopper')
-rw-r--r--testing/voiphopper/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/testing/voiphopper/APKBUILD b/testing/voiphopper/APKBUILD
new file mode 100644
index 000000000..1a02cae9a
--- /dev/null
+++ b/testing/voiphopper/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=voiphopper
+pkgver=2.01
+pkgrel=0
+pkgdesc="A VoIP infrastructure security testing tool"
+url="http://voiphopper.sourceforge.net"
+arch="all"
+license="GPL3"
+depends=""
+depends_dev=""
+makedepends="libpcap-dev"
+install=""
+subpackages=""
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="abb7ababb4ecd1376a097ce7446eea9c voiphopper-2.01.tar.gz"