summaryrefslogtreecommitdiffstats
path: root/testing/wbox
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2012-01-04 16:20:28 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-01-16 14:50:44 +0000
commiteef2c0e1fdbe700776d80dd24232d71b4d3bf0ab (patch)
treec5e05326f4b86c482858260f1baa816378533bf2 /testing/wbox
parent1367bc1c354e1a0a009ced0483ad9971574df80d (diff)
downloadaports-eef2c0e1fdbe700776d80dd24232d71b4d3bf0ab.tar.bz2
aports-eef2c0e1fdbe700776d80dd24232d71b4d3bf0ab.tar.xz
Initial APKBUILD for wbox
Package description: Wbox aims to help you having fun while testing HTTP related stuff. You can use it to perform many tasks, including the following. * Benchmarking how much time it takes to generate content for your web application. * Web server and web application stressing. * Testing virtual domains configuration without the need to alter your local resolver. * Check if your redirects are working correctly emitting the right HTTP code. * Test if the HTTP compression is working and if it is actually serving pages faster. * Use it as a configuration-less HTTP server to share files! Website: http://www.hping.org/wbox/
Diffstat (limited to 'testing/wbox')
-rw-r--r--testing/wbox/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/wbox/APKBUILD b/testing/wbox/APKBUILD
new file mode 100644
index 000000000..d32a05d77
--- /dev/null
+++ b/testing/wbox/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=wbox
+pkgver=5
+pkgrel=0
+pkgdesc="HTTP testing tool and configuration-less HTTP server"
+url="http://www.hping.org/wbox/"
+arch="all"
+license="BSD"
+depends=""
+depends_dev=""
+makedepends=""
+install=""
+subpackages=""
+source="http://www.hping.org/wbox/$pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -m755 -D "$_builddir"/$pkgname "$pkgdir"/usr/bin/$pkgname
+}
+
+md5sums="a95ca2c69982db10704b5ed482c9c722 wbox-5.tar.gz"