summaryrefslogtreecommitdiffstats
path: root/testing/willie
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-30 11:22:48 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2013-09-30 11:22:48 +0000
commit699fab80781e1b543a9a33aaf6141c1f98cf1ddc (patch)
tree10ac73d81be716807deba76a1054979f41c70411 /testing/willie
parentfa4763b7bbe10744c40cfd8b34b9f92a0fe89d8a (diff)
downloadaports-699fab80781e1b543a9a33aaf6141c1f98cf1ddc.tar.bz2
aports-699fab80781e1b543a9a33aaf6141c1f98cf1ddc.tar.xz
testing/willie: new aport
A lightweight and easy-to-use IRC Utility bot http://willie.dftba.net/
Diffstat (limited to 'testing/willie')
-rw-r--r--testing/willie/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/willie/APKBUILD b/testing/willie/APKBUILD
new file mode 100644
index 000000000..a6533d6dd
--- /dev/null
+++ b/testing/willie/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=willie
+pkgver=4.0.1
+pkgrel=0
+pkgdesc="A lightweight and easy-to-use IRC Utility bot"
+url="http://willie.dftba.net/"
+arch="noarch"
+license="EFL 2.0"
+depends="python py-tz py-lxml py-feedparser py-enchant py-geoip py-praw
+ py-openssl py-mysqldb"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://willie.dftba.net/files/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="cca8bb85b8b41ba6e3d3dd84f7353f6b willie-4.0.1.tar.gz"
+sha256sums="ce6e28f1bd31137f46e1173eb268889f8546687c77604a33bbce78d3584ec939 willie-4.0.1.tar.gz"
+sha512sums="f59ac999f1e3070289e951f26791b36f907d3bc40ed84c54f7d53d32ef8473f2f16c6a35ab050f32dde8a12ee1bd96534e14aad941f2086fb8460f906214aa0c willie-4.0.1.tar.gz"