summaryrefslogtreecommitdiffstats
path: root/testing/wxformbuilder
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-07-15 11:08:55 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-07-15 11:08:55 +0000
commit5701f80cfd383c97473a40e81e7b7bb2caeb263f (patch)
treed8b735f460edf1533864e6684b1b0f587152493d /testing/wxformbuilder
parentcef6611406a5c484e38175f3f44e0a707ec6058e (diff)
downloadaports-5701f80cfd383c97473a40e81e7b7bb2caeb263f.tar.bz2
aports-5701f80cfd383c97473a40e81e7b7bb2caeb263f.tar.xz
testing/wxformbuilder: new aport
RAD tool for wxWidgets GUI design http://sourceforge.net/apps/wordpress/wxformbuilder
Diffstat (limited to 'testing/wxformbuilder')
-rw-r--r--testing/wxformbuilder/APKBUILD41
-rw-r--r--testing/wxformbuilder/libdl.patch11
2 files changed, 52 insertions, 0 deletions
diff --git a/testing/wxformbuilder/APKBUILD b/testing/wxformbuilder/APKBUILD
new file mode 100644
index 000000000..c14d6b71d
--- /dev/null
+++ b/testing/wxformbuilder/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=wxformbuilder
+pkgver=3.0.57
+pkgrel=0
+pkgdesc="RAD tool for wxWidgets GUI design"
+url="http://sourceforge.net/apps/wordpress/wxformbuilder"
+arch="all"
+license="GPLv2"
+depends=""
+depends_dev=""
+makedepends="$depends_dev wxgtk-dev"
+install=""
+subpackages=""
+source="http://downloads.sourceforge.net/project/wxformbuilder/wxformbuilder-src/$pkgver/wxformbuilder-$pkgver.tar.gz
+ libdl.patch"
+
+_builddir="$srcdir"/wxformbuilder_$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make CONFIG=Release || return 1
+}
+
+package() {
+ cd "$_builddir"
+ mkdir -p "$pkgdir"/usr
+ install/linux/wxfb_export.sh "$pkgdir"/usr || return 1
+}
+
+md5sums="77dd368b2ec4ec5a583e1ab60c344a12 wxformbuilder-3.0.57.tar.gz
+a4917ec9c4afbb848a07e6a44f6c4924 libdl.patch"
diff --git a/testing/wxformbuilder/libdl.patch b/testing/wxformbuilder/libdl.patch
new file mode 100644
index 000000000..cc0be82ae
--- /dev/null
+++ b/testing/wxformbuilder/libdl.patch
@@ -0,0 +1,11 @@
+--- ./src/Makefile.orig
++++ ./src/Makefile
+@@ -5,6 +5,8 @@
+ CONFIG=Release
+ endif
+
++LDFLAGS += -ldl
++
+ ifeq ($(CONFIG),Release)
+ BINDIR := ../output/bin
+ LIBDIR := ..