summaryrefslogtreecommitdiffstats
path: root/testing/xfce4-volumed
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-09-10 10:01:24 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-09-10 13:04:09 +0000
commitab81a1224d640415bf68fc5fded300b3004639d6 (patch)
treee4faaf712fae8c789dd4e7956bfae1b614ca245a /testing/xfce4-volumed
parent74b4723b046da408497f1f891b664a04aed37e07 (diff)
downloadaports-ab81a1224d640415bf68fc5fded300b3004639d6.tar.bz2
aports-ab81a1224d640415bf68fc5fded300b3004639d6.tar.xz
testing/xfce4-volumed: new aport
Daemon to add additional functionality to the volume keys of the keyboard https://launchpad.net/xfce4-volumed
Diffstat (limited to 'testing/xfce4-volumed')
-rw-r--r--testing/xfce4-volumed/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/testing/xfce4-volumed/APKBUILD b/testing/xfce4-volumed/APKBUILD
new file mode 100644
index 000000000..d56f0c96f
--- /dev/null
+++ b/testing/xfce4-volumed/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xfce4-volumed
+pkgver=0.1.13
+pkgrel=0
+pkgdesc="Daemon to add additional functionality to the volume keys of the keyboard"
+url="https://launchpad.net/xfce4-volumed"
+arch="all"
+license="GPLv3+"
+depends="xfce4-mixer"
+makedepends="xfconf-dev libnotify-dev gst-plugins-base-dev keybinder-dev"
+install=""
+subpackages=""
+source="http://archive.xfce.org/src/apps/xfce4-volumed/0.1/xfce4-volumed-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/xfce4-volumed-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="03c0ee58aa0a080d35313ac517a975ea xfce4-volumed-0.1.13.tar.bz2"