summaryrefslogtreecommitdiffstats
path: root/testing/zeromq
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-12-09 08:03:32 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-12-09 08:04:36 +0000
commitd47ae2218cbdf17266849fb9ee8a1dc661149bd5 (patch)
treece244f5279b32568dbe232184d0283f410457b0f /testing/zeromq
parentec3bb64c113cab02b963821fbae20981ee4d00d6 (diff)
downloadaports-d47ae2218cbdf17266849fb9ee8a1dc661149bd5.tar.bz2
aports-d47ae2218cbdf17266849fb9ee8a1dc661149bd5.tar.xz
testing/zeromq: new aport
The ZeroMQ messaging library and tools http://www.zeromq.org/
Diffstat (limited to 'testing/zeromq')
-rw-r--r--testing/zeromq/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/testing/zeromq/APKBUILD b/testing/zeromq/APKBUILD
new file mode 100644
index 000000000..a014aa13a
--- /dev/null
+++ b/testing/zeromq/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=zeromq
+pkgver=2.0.10
+pkgrel=0
+pkgdesc="The ZeroMQ messaging library and tools"
+url="http://www.zeromq.org/"
+license="LGPLv3+"
+depends=
+makedepends="util-linux-ng-dev"
+install=
+subpackages="$pkgname-dev $pkgname-doc libzmq"
+source="http://download.zeromq.org/zeromq-$pkgver.tar.gz"
+
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+libzmq() {
+ pkgdesc="The ZeroMQ messaging library"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/libzmq.so.* "$subpkgdir"/usr/lib/
+}
+
+md5sums="ab794a174210b9e8096a4efd1d1a4d42 zeromq-2.0.10.tar.gz"