summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJeff Bilyk <jbilyk@gmail.com>2010-09-09 22:12:39 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-09-14 12:56:15 +0000
commit060fd2b507c3e553781cd5d5bbcd112d5957d955 (patch)
tree4da3caeb74f49ca56b4f43bd921a87199d887801 /testing
parent69e84b00fdb60441b58116ae4dc156f0bdd8934b (diff)
downloadaports-060fd2b507c3e553781cd5d5bbcd112d5957d955.tar.bz2
aports-060fd2b507c3e553781cd5d5bbcd112d5957d955.tar.xz
testing/apache-mod-auth-ntlm-winbind: new aport
fixes #414
Diffstat (limited to 'testing')
-rw-r--r--testing/apache-mod-auth-ntlm-winbind/APKBUILD34
-rw-r--r--testing/apache-mod-auth-ntlm-winbind/mod-auth-ntlm-winbind.conf1
2 files changed, 35 insertions, 0 deletions
diff --git a/testing/apache-mod-auth-ntlm-winbind/APKBUILD b/testing/apache-mod-auth-ntlm-winbind/APKBUILD
new file mode 100644
index 000000000..2a9bba0d9
--- /dev/null
+++ b/testing/apache-mod-auth-ntlm-winbind/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Jeff Bilyk <jbilyk@gmail.com>
+# Maintainer: Natanael Copa <natanael.copa@gmail.com>
+pkgname=apache-mod-auth-ntlm-winbind
+pkgver=0.1
+pkgrel=0
+pkgdesc="Authentication module for Apache using NTLM protocol with winbind helper"
+url="http://samba.org/ftp/unpacked/lorikeet/mod_auth_ntlm_winbind/"
+license="Apache2"
+depends="apache2"
+makedepends="autoconf apache2-dev apr-util-dev apr-dev"
+source="http://samba.org/ftp/unpacked/lorikeet/mod_auth_ntlm_winbind/mod_auth_ntlm_winbind.c
+http://samba.org/ftp/unpacked/lorikeet/mod_auth_ntlm_winbind/configure.in
+http://samba.org/ftp/unpacked/lorikeet/mod_auth_ntlm_winbind/Makefile.in
+mod-auth-ntlm-winbind.conf"
+
+build() {
+ cd "$srcdir"
+ autoconf
+ ./configure
+ make DESTDIR="$pkgdir" || return 1
+}
+
+package() {
+ cd "$srcdir"
+ mkdir -p "$pkgdir"/etc/apache2/conf.d
+ mkdir -p "$pkgdir"/usr/lib/apache2
+ install mod-auth-ntlm-winbind.conf "$pkgdir"/etc/apache2/conf.d/mod-auth-ntlm-winbind.conf
+ install "$srcdir"/.libs/mod_auth_ntlm_winbind.so "$pkgdir"/usr/lib/apache2/mod_auth_ntlm_winbind.so
+}
+
+md5sums="01d32e311e6a404bcf4179c863081818 mod_auth_ntlm_winbind.c
+e1490dae6e468d4bc56154b16e5d8c24 configure.in
+410de8b0ac7ffe5c44a71d094190187d Makefile.in
+331b392c7aaa13b3a9ea8780ce2db3d4 mod-auth-ntlm-winbind.conf"
diff --git a/testing/apache-mod-auth-ntlm-winbind/mod-auth-ntlm-winbind.conf b/testing/apache-mod-auth-ntlm-winbind/mod-auth-ntlm-winbind.conf
new file mode 100644
index 000000000..da7d99133
--- /dev/null
+++ b/testing/apache-mod-auth-ntlm-winbind/mod-auth-ntlm-winbind.conf
@@ -0,0 +1 @@
+LoadModule auth_ntlm_winbind_module lib/apache2/mod_auth_ntlm_winbind.so