summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <bpiotrowski@alpinelinux.org>2013-07-20 15:56:32 +0200
committerBartłomiej Piotrowski <bpiotrowski@alpinelinux.org>2013-07-20 15:56:54 +0200
commit0fb7f1304c26bdde70f2bf695da82370520229b8 (patch)
treecf37f3f5622a9f2d2b14a2e383c9c824e8224d29 /testing
parent93bf62e560b1e71d21791da0108cfbf8bea7236b (diff)
downloadaports-0fb7f1304c26bdde70f2bf695da82370520229b8.tar.bz2
aports-0fb7f1304c26bdde70f2bf695da82370520229b8.tar.xz
testing/nodejs: upgrade to 0.10.13
Diffstat (limited to 'testing')
-rw-r--r--testing/nodejs/APKBUILD55
-rw-r--r--testing/nodejs/nodejs-multiplicity.patch10
-rw-r--r--testing/nodejs/nodejs-uclibc.patch20
3 files changed, 18 insertions, 67 deletions
diff --git a/testing/nodejs/APKBUILD b/testing/nodejs/APKBUILD
index fe5acb8e0..e6d74cfe4 100644
--- a/testing/nodejs/APKBUILD
+++ b/testing/nodejs/APKBUILD
@@ -1,48 +1,29 @@
+# Maintainer: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
# Contributor: William Pitcock <nenolod@dereferenced.org>
-# Maintainer:
+
pkgname=nodejs
-pkgver=0.4.2
+pkgver=0.10.13
pkgrel=0
-pkgdesc="event-oriented javascript framework and execution environment"
-url="http://nodejs.org/"
-
-# v8 is not portable so we have to list archs by hand
-arch="x86 x86_64 arm"
-
-license="MIT BSD Apache-2"
-depends=
-depends_dev=
-makedepends="$depends_dev python libev-dev c-ares-dev openssl-dev"
-install=""
+pkgdesc='Evented I/O for V8 javascript'
+url='http://nodejs.org/'
+arch='all'
+license='MIT'
+makedepends="$depends_dev python openssl-dev"
subpackages="$pkgname-dev $pkgname-doc"
-source="http://nodejs.org/dist/node-v${pkgver}.tar.gz
- nodejs-uclibc.patch
- nodejs-multiplicity.patch"
-
-_builddir="${srcdir}/node-v${pkgver}"
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+source="http://nodejs.org/dist/v$pkgver/node-v$pkgver.tar.gz"
build() {
- cd "$_builddir"
- ./configure --prefix=/usr \
- --shared-cares \
- --shared-libev
- make || return 1
+ cd "$srcdir"/node-v$pkgver
+ ./configure --prefix=/usr \
+ --shared-openssl || return 1
+ make || return 1
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$srcdir"/node-v$pkgver
+ make DESTDIR="$pkgdir" install || return 1
}
-md5sums="9e9e791e125f6a601ebc663dc99c72a8 node-v0.4.2.tar.gz
-b5d7568f58bb9a14d5b9a971e89560c6 nodejs-uclibc.patch
-912d504d56fb194b4ceda8f693f6e200 nodejs-multiplicity.patch"
+md5sums="4c8185732680fc70c90a4c39789e4ff0 node-v0.10.13.tar.gz"
+sha256sums="a102fad260d216b95611ddd57aeb6531c92ad1038508390654423feb1b51c059 node-v0.10.13.tar.gz"
+sha512sums="d632bdb56999b6281f1d77f8e769605e9c90a7de9ef2d285879bac3ac0f66675a789a76a48282c8e0801bab3a4412630b1b2f01c3b8584176095c47aeb8e9a76 node-v0.10.13.tar.gz"
diff --git a/testing/nodejs/nodejs-multiplicity.patch b/testing/nodejs/nodejs-multiplicity.patch
deleted file mode 100644
index 87479690d..000000000
--- a/testing/nodejs/nodejs-multiplicity.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- node-v0.4.2.orig/wscript
-+++ node-v0.4.2/wscript
-@@ -436,7 +436,6 @@
- # LFS
- conf.env.append_value('CPPFLAGS', '-D_LARGEFILE_SOURCE')
- conf.env.append_value('CPPFLAGS', '-D_FILE_OFFSET_BITS=64')
-- conf.env.append_value('CPPFLAGS', '-DEV_MULTIPLICITY=0')
-
- # Makes select on windows support more than 64 FDs
- if sys.platform.startswith("win32"):
diff --git a/testing/nodejs/nodejs-uclibc.patch b/testing/nodejs/nodejs-uclibc.patch
deleted file mode 100644
index 68fadff06..000000000
--- a/testing/nodejs/nodejs-uclibc.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- node-v0.4.2.orig/deps/v8/src/platform-linux.cc
-+++ node-v0.4.2/deps/v8/src/platform-linux.cc
-@@ -46,7 +46,7 @@
- #include <sys/stat.h> // open
- #include <fcntl.h> // open
- #include <unistd.h> // sysconf
--#ifdef __GLIBC__
-+#if defined(__GLIBC__) && !defined(__UCLIBC__)
- #include <execinfo.h> // backtrace, backtrace_symbols
- #endif // def __GLIBC__
- #include <strings.h> // index
-@@ -447,7 +447,7 @@
-
- int OS::StackWalk(Vector<OS::StackFrame> frames) {
- // backtrace is a glibc extension.
--#ifdef __GLIBC__
-+#if defined(__GLIBC__) && !defined(__UCLIBC__)
- int frames_size = frames.length();
- ScopedVector<void*> addresses(frames_size);
-