summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2014-03-04 22:12:14 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-03-11 07:33:01 +0000
commit3b220e1ad48038c12fdf34cbcb22de55151e0e08 (patch)
tree29a8517182c854a70ff33ead37c5848c60f53ef1 /testing
parent70efd480edc5184f5bf08797e6041b58cb49a7b9 (diff)
downloadaports-3b220e1ad48038c12fdf34cbcb22de55151e0e08.tar.bz2
aports-3b220e1ad48038c12fdf34cbcb22de55151e0e08.tar.xz
testing/py-impacket: new aport
A collection of Python classes providing access to network packets http://code.google.com/p/impacket/
Diffstat (limited to 'testing')
-rw-r--r--testing/py-impacket/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-impacket/APKBUILD b/testing/py-impacket/APKBUILD
new file mode 100644
index 000000000..2384a271a
--- /dev/null
+++ b/testing/py-impacket/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-impacket
+_pkgname=impacket
+pkgver=0.9.11
+pkgrel=0
+pkgdesc="A collection of Python classes providing access to network packets"
+url="http://code.google.com/p/impacket/"
+arch="noarch"
+license="ASL 2.0"
+depends="python"
+depends_dev=""
+makedepends="python-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="be93b861437aa0721a4d6904a292f5c6 impacket-0.9.11.tar.gz"
+sha256sums="e0b4e5174b869efa35c3068ee55ac3c2364706b59ffc43cd9e3c2f75f5accf2d impacket-0.9.11.tar.gz"
+sha512sums="b825437fab65cbf799a62d30ff0749f139f0f16a9a01d9d2ff0fc86be92333b72a7f94ed5fce24dda87212b0c23fa2bcd872e1b6c6143e8528eaa11c920c7a6d impacket-0.9.11.tar.gz"