summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-09-07 11:45:49 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-09-07 11:45:49 +0000
commit5576e1726de9519b2874d1bb0d3004540106bb7a (patch)
treeacc4f9ef302f155e2a319c7ce2c9c1a2f60cd168 /testing
parent8b8be5b45391c1abe678bead92ddb2933c32c8a5 (diff)
downloadaports-5576e1726de9519b2874d1bb0d3004540106bb7a.tar.bz2
aports-5576e1726de9519b2874d1bb0d3004540106bb7a.tar.xz
testing/lua-imlib2: new aport
A LUA binding to the Imlib2 image manipulation library http://asbradbury.org/projects/lua-imlib2/
Diffstat (limited to 'testing')
-rw-r--r--testing/lua-imlib2/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/lua-imlib2/APKBUILD b/testing/lua-imlib2/APKBUILD
new file mode 100644
index 000000000..4b8cea2f4
--- /dev/null
+++ b/testing/lua-imlib2/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor:
+# Maintainer:
+pkgname=lua-imlib2
+pkgver=0.1
+pkgrel=0
+pkgdesc="A LUA binding to the Imlib2 image manipulation library"
+url="http://asbradbury.org/projects/lua-imlib2/"
+license="MIT"
+depends=
+makedepends="lua-dev imlib2-dev"
+install=
+source="http://luaforge.net/frs/download.php/3042/lua-imlib2-$pkgver.tar.gz"
+
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -D limlib2.so "$pkgdir"/usr/lib/lua/5.1/limlib2.so
+ install -D imlib2.lua "$pkgdir"/usr/share/lua/5.1/imlib2.lua
+}
+
+md5sums="f90d5d70ea8af6b66ee2e3071a08ec00 lua-imlib2-0.1.tar.gz"