summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-01-12 13:47:48 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-01-12 13:48:34 +0000
commit699d5bb6368cc7e3c05b136feaf42a542551d5f7 (patch)
tree10042ed0d56f939c9f8060997ad0017a91176d72 /testing
parent74380c96c7714c02d63e88eda30604887bc5c82f (diff)
downloadaports-699d5bb6368cc7e3c05b136feaf42a542551d5f7.tar.bz2
aports-699d5bb6368cc7e3c05b136feaf42a542551d5f7.tar.xz
testing/libgexiv2: new aport
a GObject-based wrapper around the Exiv2 library http://trac.yorba.org/wiki/gexiv2
Diffstat (limited to 'testing')
-rw-r--r--testing/libgexiv2/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/libgexiv2/APKBUILD b/testing/libgexiv2/APKBUILD
new file mode 100644
index 000000000..5c4a7a28e
--- /dev/null
+++ b/testing/libgexiv2/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libgexiv2
+pkgver=0.3.0
+pkgrel=0
+pkgdesc="a GObject-based wrapper around the Exiv2 library"
+url="http://trac.yorba.org/wiki/gexiv2"
+arch="all"
+license="GPL"
+depends=
+depends_dev="glib-dev exiv2-dev"
+makedepends="exiv2-dev glib-dev libtool m4"
+install=
+subpackages="$pkgname-dev"
+source="http://yorba.org/download/gexiv2/${pkgver%.*}/libgexiv2-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="b6b2b2ae3c7d57a85d8c346b418ff98c libgexiv2-0.3.0.tar.bz2"