summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-07-27 07:24:41 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-07-27 07:24:41 +0000
commit6a74f0064cfb6554de47f73b56c9c58e2914fe9f (patch)
treea56f0b702c34faf8dceea8f4bd4499a12606c6c7 /testing
parent28d08f8ac2796f1be43712d277540a1aeac932e6 (diff)
downloadaports-6a74f0064cfb6554de47f73b56c9c58e2914fe9f.tar.bz2
aports-6a74f0064cfb6554de47f73b56c9c58e2914fe9f.tar.xz
testing/cmph: new aport
minimal perfect hash C library - utility application http://cmph.sourceforge.net/
Diffstat (limited to 'testing')
-rw-r--r--testing/cmph/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/cmph/APKBUILD b/testing/cmph/APKBUILD
new file mode 100644
index 000000000..a52b0bcf1
--- /dev/null
+++ b/testing/cmph/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor:
+# Maintainer:
+pkgname=cmph
+pkgver=0.9
+pkgrel=0
+pkgdesc="minimal perfect hash C library - utility application"
+url="http://cmph.sourceforge.net/"
+license="LGPL MPL-1.1"
+depends=
+makedepends=
+install=
+subpackages="$pkgname-dev $pkgname-doc libcmph:lib"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+lib() {
+ pkgdesc="minimal perfect hash C library - utility application"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/libcmph*.so.* "$subpkgdir"/usr/lib/
+}
+
+md5sums="14c17e3058174e9333936caa8e18ed28 cmph-0.9.tar.gz"