summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-09-10 10:01:09 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-09-10 13:04:08 +0000
commit74b4723b046da408497f1f891b664a04aed37e07 (patch)
tree7d49d1d48e04794d4ae52b40adbaa503b65d57c2 /testing
parent578502bd3937a02ce987d5cbae3ab6f7c6d6f831 (diff)
downloadaports-74b4723b046da408497f1f891b664a04aed37e07.tar.bz2
aports-74b4723b046da408497f1f891b664a04aed37e07.tar.xz
testing/keybinder: new aport
A library for registering global keyboard shortcuts http://kaizer.se/wiki/keybinder/
Diffstat (limited to 'testing')
-rw-r--r--testing/keybinder/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/testing/keybinder/APKBUILD b/testing/keybinder/APKBUILD
new file mode 100644
index 000000000..3f5eefeaa
--- /dev/null
+++ b/testing/keybinder/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=keybinder
+pkgver=0.3.0
+pkgrel=0
+pkgdesc="A library for registering global keyboard shortcuts"
+url="http://kaizer.se/wiki/keybinder/"
+arch="all"
+license="MIT"
+depends=""
+depends_dev="gtk+2.0-dev libxext-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://kaizer.se/publicfiles/keybinder/keybinder-$pkgver.tar.gz"
+
+_builddir="$srcdir"/keybinder-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --disable-static \
+ --disable-python \
+ --disable-lua \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="2a0aed62ba14d1bf5c79707e20cb4059 keybinder-0.3.0.tar.gz"