summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-10-20 19:58:04 +0300
committerTimo Teräs <timo.teras@iki.fi>2013-10-20 19:59:18 +0300
commit846c523146995c5a8cf777bb65d08251287635cf (patch)
tree8ac008790ec75b9151ec1c2509d947f54ac7365e /testing
parente44aa67bc10e4ae37a2c415056e689194f7c4ce3 (diff)
downloadaports-846c523146995c5a8cf777bb65d08251287635cf.tar.bz2
aports-846c523146995c5a8cf777bb65d08251287635cf.tar.xz
testing/zoneminder: minor fixes, disable x86
Does not build for x86 due to: zm_utils.cpp: In function 'void ssedetect()': zm_utils.cpp:167:3: error: PIC register clobbered by '%ebx' in 'asm' zm_image.cpp: In function 'void ssse3_deinterlace_4field_gray8(uint8_t*, uint8_t*, unsigned int, unsigned int, unsigned int)': zm_image.cpp:4780:3: error: 'asm' operand has impossible constraints The assembly parts need proper PIC support.
Diffstat (limited to 'testing')
-rw-r--r--testing/zoneminder/APKBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/testing/zoneminder/APKBUILD b/testing/zoneminder/APKBUILD
index 21ca09c66..e095df096 100644
--- a/testing/zoneminder/APKBUILD
+++ b/testing/zoneminder/APKBUILD
@@ -4,8 +4,8 @@ pkgname=zoneminder
pkgver=1.26.4
pkgrel=0
pkgdesc="Video camera surveillance system"
-url=http://www.zoneminder.com/
-arch=all
+url="http://www.zoneminder.com/"
+arch="x86"
license=GPL-2
depends="apache2 ffmpeg libbz2 libjpeg-turbo mysql-client pcre perl
@@ -41,8 +41,9 @@ build() {
--prefix=/usr \
--sysconfdir=/etc \
--with-webdir=/var/www/localhost/htdocs \
- --with-cgidir=/var/www/cgi-bin
- make
+ --with-cgidir=/var/www/cgi-bin \
+ || return 1
+ make || return 1
}
package() {