summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-11-28 15:35:47 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-11-28 15:37:01 +0000
commit8697df6813e7127582f99cb8229757e094d916e8 (patch)
tree044d589f412e1bc1a028f31d18202b635d72c8b8 /testing
parentc222291c217af8167947fadb4de560553e15ada2 (diff)
downloadaports-8697df6813e7127582f99cb8229757e094d916e8.tar.bz2
aports-8697df6813e7127582f99cb8229757e094d916e8.tar.xz
testing/mqtt-exec: new aport
simple MQTT client that executes a command on messages https://github.com/ncopa/mqtt-exec
Diffstat (limited to 'testing')
-rw-r--r--testing/mqtt-exec/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/mqtt-exec/APKBUILD b/testing/mqtt-exec/APKBUILD
new file mode 100644
index 000000000..091778779
--- /dev/null
+++ b/testing/mqtt-exec/APKBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=mqtt-exec
+pkgver=0.1
+pkgrel=0
+pkgdesc="simple MQTT client that executes a command on messages"
+url="https://github.com/ncopa/mqtt-exec"
+arch="all"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends="$depends_dev mosquitto-dev"
+install=""
+subpackages=""
+source="mqtt-exec-$pkgver.tar.gz::https://github.com/ncopa/mqtt-exec/archive/v$pkgver.tar.gz"
+
+_builddir="$srcdir"/mqtt-exec-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -D mqtt-exec "$pkgdir"/usr/bin/mqtt-exec
+}
+
+md5sums="1e78b343ecd7cc64d2771dcd04dfc2d7 mqtt-exec-0.1.tar.gz"
+sha256sums="4a62dc42131ba9c2ba418818e7394981c81c8f0a53cc31619a7d45247f6d376e mqtt-exec-0.1.tar.gz"
+sha512sums="583d02e7d1a0b7cb7bb9a249a7581109d0d48b6c9a0acc77022cfe2e8db56f8295a41c9374b0671343a215280b1d8cf36346501cabae157d6235170b7ee7d6ea mqtt-exec-0.1.tar.gz"