summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorEivind Uggedal <eivind@uggedal.com>2013-11-29 13:02:43 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-11-29 14:00:53 +0000
commita6a2efc2c569bbd3752ed2331ed414587147dc99 (patch)
treeb16640024d072e1e23f62c1b38a529b1d947e6c2 /testing
parent3284ea09fae9d60b9eae4914adbfee2fc99a2243 (diff)
downloadaports-a6a2efc2c569bbd3752ed2331ed414587147dc99.tar.bz2
aports-a6a2efc2c569bbd3752ed2331ed414587147dc99.tar.xz
testing/bash-completion: remove conflicting files
remove some completion files conflicting with files provided upstream from util-linux and networkmanager.
Diffstat (limited to 'testing')
-rw-r--r--testing/bash-completion/APKBUILD27
1 files changed, 26 insertions, 1 deletions
diff --git a/testing/bash-completion/APKBUILD b/testing/bash-completion/APKBUILD
index fcd11f649..ac8d8c834 100644
--- a/testing/bash-completion/APKBUILD
+++ b/testing/bash-completion/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=bash-completion
pkgver=2.1
-pkgrel=0
+pkgrel=1
pkgdesc="Command-line tab-completion for bash"
url="http://bash-completion.alioth.debian.org/"
arch="noarch"
@@ -14,6 +14,26 @@ install=""
source="http://ftp.debian.org/debian/pool/main/b/bash-completion/${pkgname}_${pkgver}.orig.tar.bz2"
_builddir="$srcdir"/$pkgname-$pkgver
+
+# Provided with util-linux and networkmanager:
+_conflicting="
+ cal
+ chsh
+ dmesg
+ eject
+ hd
+ hexdump
+ hwclock
+ ionice
+ look
+ ncal
+ newgrp
+ renice
+ rtcwake
+ su
+ nmcli
+ "
+
prepare() {
local i
cd "$_builddir"
@@ -35,6 +55,11 @@ build() {
package() {
cd "$_builddir"
make -j1 DESTDIR="$pkgdir" install || return 1
+
+ cd "$pkgdir"/usr/share/bash-completion/completions
+ for c in $_conflicting; do
+ rm $c
+ done
}
md5sums="4e2a9f11a4042a38ee79ddcd048e8b9e bash-completion_2.1.orig.tar.bz2"