summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2012-01-14 23:08:56 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-01-16 15:49:59 +0000
commita76dfe500f2265bee948f900bc407ab8aff0854e (patch)
treec417ad73802229ba3a3a4465123e740ca8b42c6b /testing
parent8816815fcca33cba0c48a6315f032c72da0e7356 (diff)
downloadaports-a76dfe500f2265bee948f900bc407ab8aff0854e.tar.bz2
aports-a76dfe500f2265bee948f900bc407ab8aff0854e.tar.xz
Initial APKBUILD for nettle
Package description: Nettle is a cryptographic library that is designed to fit easily in more or less any context: In crypto toolkits for object-oriented languages (C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in kernel space. Website: http://www.lysator.liu.se/~nisse/nettle/
Diffstat (limited to 'testing')
-rw-r--r--testing/nettle/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/testing/nettle/APKBUILD b/testing/nettle/APKBUILD
new file mode 100644
index 000000000..5fe4356b9
--- /dev/null
+++ b/testing/nettle/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch
+pkgname=nettle
+pkgver=2.4
+pkgrel=0
+pkgdesc="A low-level cryptographic library"
+url="http://www.lysator.liu.se/~nisse/nettle/"
+arch="all"
+license="LGPL2+"
+depends=""
+depends_dev="gmp-dev m4"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="ftp://ftp.lysator.liu.se/pub/security/lsh/$pkgname-$pkgver.tar.gz
+ nettle-2.4-makefile.patch"
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --enable-shared \
+ --disable-openssl \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="450be8c4886d46c09f49f568ad6fa013 nettle-2.4.tar.gz
+b3a89964557b9fca040a84e9217b4b01 nettle-2.4-makefile.patch"