summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-06-25 07:04:09 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-06-25 07:04:09 +0000
commitb3b34063b8bc6601ea766346514efa8b67b69946 (patch)
tree097fa01352278d500d28ddfaeccc4d1d84952825 /testing
parentd470b0145b44d801ee78606a6428135f228e5ee1 (diff)
downloadaports-b3b34063b8bc6601ea766346514efa8b67b69946.tar.bz2
aports-b3b34063b8bc6601ea766346514efa8b67b69946.tar.xz
testing/lua5.2-cjson: new aport
fast JSON parsing and encoding support for Lua 5.2 http://www.kyne.com.au/~mark/software/lua-cjson.php
Diffstat (limited to 'testing')
-rw-r--r--testing/lua5.2-cjson/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/lua5.2-cjson/APKBUILD b/testing/lua5.2-cjson/APKBUILD
new file mode 100644
index 000000000..82a7ae2d1
--- /dev/null
+++ b/testing/lua5.2-cjson/APKBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+_luaver=5.2
+pkgname=lua${_luaver}-cjson
+pkgver=2.1.0
+pkgrel=0
+pkgdesc="fast JSON parsing and encoding support for Lua $_luaver"
+url="http://www.kyne.com.au/~mark/software/lua-cjson.php"
+arch="all"
+license="MIT"
+depends=""
+makedepends="lua${_luaver}-dev"
+install=""
+subpackages=""
+source="http://www.kyne.com.au/~mark/software/download/lua-cjson-$pkgver.tar.gz"
+
+_builddir="$srcdir"/lua-cjson-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ sed -i -e "/^LUA_VERSION\s*=/s/=.*/= $_luaver/" Makefile
+}
+
+build() {
+ cd "$_builddir"
+ make CFLAGS_EXTRA= PREFIX=/usr|| return 1
+}
+
+package() {
+ cd "$_builddir"
+ make PREFIX=/usr DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="24f270663e9f6ca8ba2a02cef19f7963 lua-cjson-2.1.0.tar.gz"
+sha256sums="51bc69cd55931e0cba2ceae39e9efa2483f4292da3a88a1ed470eda829f6c778 lua-cjson-2.1.0.tar.gz"
+sha512sums="4343513b942f2ed98dc1ea6d7e852303bc1263f8acc5c70c8d674aec7adfc8279c5af7d5173a417b6f9a74543b8f6c8f98742d002f4f75832bbf23bb5a30ad2f lua-cjson-2.1.0.tar.gz"