summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2012-12-30 12:54:01 +0100
committerCarlo Landmeter <clandmeter@gmail.com>2012-12-30 12:54:01 +0100
commitf95cb4b53f7b2667c06d2ec6e4cdca0170668204 (patch)
tree096602846bb94012a8c0eee54116494ec9958d40 /testing
parentaebeda59ca36e6efe93cdd8e5d7b5d9c1e247af6 (diff)
downloadaports-f95cb4b53f7b2667c06d2ec6e4cdca0170668204.tar.bz2
aports-f95cb4b53f7b2667c06d2ec6e4cdca0170668204.tar.xz
main/linux-vanilla: upgrade to 3.7.1
Diffstat (limited to 'testing')
-rw-r--r--testing/linux-vanilla/APKBUILD9
-rw-r--r--testing/linux-vanilla/dvb-realtek-usbid.patch21
-rw-r--r--testing/linux-vanilla/kernelconfig.x863
-rw-r--r--testing/linux-vanilla/kernelconfig.x86_643
4 files changed, 29 insertions, 7 deletions
diff --git a/testing/linux-vanilla/APKBUILD b/testing/linux-vanilla/APKBUILD
index 8452a9a25..e58d191db 100644
--- a/testing/linux-vanilla/APKBUILD
+++ b/testing/linux-vanilla/APKBUILD
@@ -2,7 +2,7 @@
_flavor=vanilla
pkgname=linux-${_flavor}
-pkgver=3.7.0
+pkgver=3.7.1
_kernver=3.7
pkgrel=0
pkgdesc="Linux kernel with grsecurity"
@@ -15,6 +15,7 @@ install=
source="http://ftp.kernel.org/pub/linux/kernel/v3.x/linux-$_kernver.tar.xz
kernelconfig.x86
kernelconfig.x86_64
+ dvb-realtek-usbid.patch
"
if [ "${pkgver%.0}" = "$pkgver" ]; then
source="$source
@@ -138,5 +139,7 @@ dev() {
}
md5sums="21223369d682bcf44bcdfe1521095983 linux-3.7.tar.xz
-b36675d027adbf9b0336622257b59edc kernelconfig.x86
-e288a0fa4fc0a150b6ba9c03c1f853a6 kernelconfig.x86_64"
+be7ce61f0adc5bd29f4b61d68da53aa9 kernelconfig.x86
+7b11068ff53d1b0bddcc74668bee9c37 kernelconfig.x86_64
+28c7b1608d7663dfa5bbdf0340a5d4f2 dvb-realtek-usbid.patch
+48f5f530b048e387e978e3e49de7742a patch-3.7.1.xz"
diff --git a/testing/linux-vanilla/dvb-realtek-usbid.patch b/testing/linux-vanilla/dvb-realtek-usbid.patch
new file mode 100644
index 000000000..0c29671f5
--- /dev/null
+++ b/testing/linux-vanilla/dvb-realtek-usbid.patch
@@ -0,0 +1,21 @@
+--- linux-3.7/drivers/media/dvb-core/dvb-usb-ids.h.orig
++++ linux-3.7/drivers/media/dvb-core/dvb-usb-ids.h
+@@ -151,6 +151,7 @@
+ #define USB_PID_KWORLD_395U_2 0xe39b
+ #define USB_PID_KWORLD_395U_3 0xe395
+ #define USB_PID_KWORLD_395U_4 0xe39a
++#define USB_PID_KWORLD_D393 0xd393
+ #define USB_PID_KWORLD_MC810 0xc810
+ #define USB_PID_KWORLD_PC160_2T 0xc160
+ #define USB_PID_KWORLD_PC160_T 0xc161
+--- linux-3.7/drivers/media/usb/dvb-usb-v2/rtl28xxu.c.orig
++++ linux-3.7/drivers/media/usb/dvb-usb-v2/rtl28xxu.c
+@@ -1350,6 +1350,8 @@
+ &rtl2832u_props, "Dexatek DK mini DVB-T Dongle", NULL) },
+ { DVB_USB_DEVICE(USB_VID_TERRATEC, 0x00d7,
+ &rtl2832u_props, "TerraTec Cinergy T Stick+", NULL) },
++ { DVB_USB_DEVICE(USB_VID_KWORLD_2, 0xd393,
++ &rtl2832u_props, "DVB-T TV Stick D393", NULL) },
+ { }
+ };
+ MODULE_DEVICE_TABLE(usb, rtl28xxu_id_table);
diff --git a/testing/linux-vanilla/kernelconfig.x86 b/testing/linux-vanilla/kernelconfig.x86
index f832f0b39..86c8c2778 100644
--- a/testing/linux-vanilla/kernelconfig.x86
+++ b/testing/linux-vanilla/kernelconfig.x86
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/i386 3.7.0 Kernel Configuration
+# Linux/i386 3.7.1 Kernel Configuration
#
# CONFIG_64BIT is not set
CONFIG_X86_32=y
@@ -4381,7 +4381,6 @@ CONFIG_USB_STORAGE_ONETOUCH=m
CONFIG_USB_STORAGE_KARMA=m
CONFIG_USB_STORAGE_CYPRESS_ATACB=m
CONFIG_USB_STORAGE_ENE_UB6250=m
-CONFIG_USB_UAS=m
#
# USB Imaging devices
diff --git a/testing/linux-vanilla/kernelconfig.x86_64 b/testing/linux-vanilla/kernelconfig.x86_64
index 65ee4f860..716b3eb40 100644
--- a/testing/linux-vanilla/kernelconfig.x86_64
+++ b/testing/linux-vanilla/kernelconfig.x86_64
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86_64 3.7.0 Kernel Configuration
+# Linux/x86_64 3.7.1 Kernel Configuration
#
CONFIG_64BIT=y
CONFIG_X86_64=y
@@ -4338,7 +4338,6 @@ CONFIG_USB_STORAGE_ONETOUCH=m
CONFIG_USB_STORAGE_KARMA=m
CONFIG_USB_STORAGE_CYPRESS_ATACB=m
CONFIG_USB_STORAGE_ENE_UB6250=m
-CONFIG_USB_UAS=m
#
# USB Imaging devices