summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/hub/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/hub/APKBUILD b/testing/hub/APKBUILD
new file mode 100644
index 000000000..3d947e444
--- /dev/null
+++ b/testing/hub/APKBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Eivind Uggedal <eivind@uggedal.com>
+pkgname=hub
+pkgver=1.10.6
+pkgrel=1
+pkgdesc="Extends git with extra features for GitHub"
+url="http://hub.github.com/"
+arch="noarch"
+license="MIT"
+depends="git ruby"
+makedepends="ruby-rake"
+install=""
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/github/hub/archive/v$pkgver.tar.gz"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$_builddir"
+ rake standalone
+}
+
+package() {
+ cd "$_builddir"
+
+ install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
+ install -D -m644 man/$pkgname.1 "$pkgdir"/usr/share/man/man1/$pkgname.1
+ install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+md5sums="b118d8f0ec3c56fcccc449fdab8a3e71 hub-1.10.6.tar.gz"
+sha256sums="0918dbaff438778707d207491fd93d5e7d8cfdb9fb9fb603b2f18814700cd46d hub-1.10.6.tar.gz"
+sha512sums="e4b3f05f32e53aeb6a54dff2400159adc1122ae21414ca92a7f812aa284daec69715c81e5dd785546a962e71c20af5c7a45f435be77ab1af57e6d4d6596c19c9 hub-1.10.6.tar.gz"