summaryrefslogtreecommitdiffstats
path: root/main/abiword/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/abiword/APKBUILD')
-rw-r--r--main/abiword/APKBUILD30
1 files changed, 13 insertions, 17 deletions
diff --git a/main/abiword/APKBUILD b/main/abiword/APKBUILD
index 5a5fcc42c..c647e33c9 100644
--- a/main/abiword/APKBUILD
+++ b/main/abiword/APKBUILD
@@ -1,14 +1,14 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=abiword
-pkgver=2.8.6
-pkgrel=14
+pkgver=3.0.0
+pkgrel=0
pkgdesc="A fully-featured word processor"
url="http://www.abisource.com"
arch="all"
license="GPL"
-makedepends="pkgconfig libglade-dev libgsf-dev enchant-dev fribidi-dev wv-dev
- popt-dev libjpeg-turbo-dev librsvg-dev bzip2-dev goffice0.8-dev pcre-dev
- autoconf automake libtool"
+makedepends="gtk+3.0-dev libgsf-dev enchant-dev fribidi-dev wv-dev
+ popt-dev libjpeg-turbo-dev librsvg-dev bzip2-dev goffice-dev pcre-dev
+ libxslt-dev"
# openxml plugin
makedepends="$makedepends boost-dev"
@@ -19,19 +19,17 @@ makedepends="$makedepends gnutls-dev libsoup-dev dbus-glib-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-plugins"
-_plugins="applix babelfish bmp clarisworks collab docbook eml freetranslation
- garble gdict gimp google hancom hrtext iscii kword loadbindings mht
- mif mswrite openwriter openxml opml paint passepartout pdb pdf
- presentation s5 sdw t602 urldict wikipedia wml xslfo"
+_plugins="applix babelfish bmp clarisworks collab docbook eml epub
+ freetranslation garble gdict gimp google hancom hrtext iscii kword
+ latex loadbindings mht mif mswrite openwriter openxml opml paint
+ passepartout pdb pdf presentation s5 sdw t602 urldict wikipedia wml
+ xslfo"
for _i in $_plugins; do
subpackages="$subpackages $pkgname-plugin-$_i:$_i"
done
source="http://www.abisource.com/downloads/$pkgname/$pkgver/source/$pkgname-$pkgver.tar.gz
- abiword-png15.patch
- abiword-2.8.6-no-undefined.patch
- abiword-2.8.6-glib-2.31.patch
"
prepare() {
@@ -41,7 +39,6 @@ prepare() {
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
esac
done
- autoreconf --force --install
}
build() {
@@ -86,7 +83,6 @@ plugins() {
mkdir -p "$subpkgdir"
}
-md5sums="f883b0a7f26229a9c66fd6a1a94381aa abiword-2.8.6.tar.gz
-1d0bb11ed10b431ab312173de81d12c4 abiword-png15.patch
-42e2614b6e0aad457d91f6ce20b6f225 abiword-2.8.6-no-undefined.patch
-2cd22b0c06cf1d285731e5bade666c26 abiword-2.8.6-glib-2.31.patch"
+md5sums="8d9c41cff3a8fbef8d0c835c65600e65 abiword-3.0.0.tar.gz"
+sha256sums="d17e318c00ff4eb353e0e7994b098b1d4f9ddd8712ac0261a0e38b89081fac01 abiword-3.0.0.tar.gz"
+sha512sums="3f9804b17f27b8afa2f5bcccdb1b5d6270339ad4f518523208f2e2cde54cb28391575cfd3639aaadc13ab50d5908260b159ca7b41fd92ed5a449d7012e5a4637 abiword-3.0.0.tar.gz"