summaryrefslogtreecommitdiffstats
path: root/main/celt051/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/celt051/APKBUILD')
-rw-r--r--main/celt051/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/main/celt051/APKBUILD b/main/celt051/APKBUILD
new file mode 100644
index 000000000..86e05c8f0
--- /dev/null
+++ b/main/celt051/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=celt051
+pkgver=0.5.1.3
+pkgrel=0
+pkgdesc="An audio codec for use in low-delay speech and audio communication"
+url="http://www.celt-codec.org/"
+arch="all"
+license="BSD"
+depends=""
+makedepends="libogg-dev"
+install=""
+subpackages="$pkgname-dev"
+source="http://downloads.us.xiph.org/releases/celt/celt-$pkgver.tar.gz"
+
+_builddir="$srcdir"/celt-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="67e7b5e45db57a6f1f0a6962f5ecb190 celt-0.5.1.3.tar.gz"