summaryrefslogtreecommitdiffstats
path: root/main/libdc1394/conditional-dc1394_vloopback.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/libdc1394/conditional-dc1394_vloopback.patch')
-rw-r--r--main/libdc1394/conditional-dc1394_vloopback.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/main/libdc1394/conditional-dc1394_vloopback.patch b/main/libdc1394/conditional-dc1394_vloopback.patch
new file mode 100644
index 000000000..308d53963
--- /dev/null
+++ b/main/libdc1394/conditional-dc1394_vloopback.patch
@@ -0,0 +1,36 @@
+From: David Moore <david.moore@gmail.com>
+Date: Mon, 28 Mar 2011 05:48:15 +0000 (-0700)
+Subject: Conditionally compile dc1394_vloopback only when linux/videodev.h exists
+X-Git-Url: http://libdc1394.git.sourceforge.net/git/gitweb.cgi?p=libdc1394%2Flibdc1394;a=commitdiff_plain;h=2ee7e7f98dd6225b40d5cd570c240504be7bc86a
+
+Conditionally compile dc1394_vloopback only when linux/videodev.h exists
+---
+
+diff --git a/configure.in b/libdc1394/configure.in
+index 69babab..bdddc9b 100644
+--- a/configure.in
++++ b/configure.in
+@@ -75,6 +75,9 @@ AM_CONDITIONAL(HAVE_WINDOWS, test x$have_windows = xtrue)
+ AM_CONDITIONAL(HAVE_LIBRAW1394, test x$libraw1394 = xtrue)
+ AM_CONDITIONAL(HAVE_LIBUSB, test "x$LIBUSB_LIBS" != "x")
+
++AC_CHECK_HEADER([linux/videodev.h], [have_videodev=true])
++AM_CONDITIONAL(HAVE_VIDEODEV, test x$have_videodev = xtrue)
++
+ AC_ARG_ENABLE([examples], [AS_HELP_STRING([--disable-examples], [don't build example programs])], [build_examples=$enableval], [build_examples=true])
+
+ AM_CONDITIONAL(MAKE_EXAMPLES, test x$build_examples = xtrue)
+diff --git a/libdc1394/examples/Makefile.am b/libdc1394/examples/Makefile.am
+index fcebf18..035612e 100644
+--- a/examples/Makefile.am
++++ b/examples/Makefile.am
+@@ -8,7 +8,9 @@ A = grab_gray_image grab_partial_image grab_color_image \
+ B = dc1394_reset_bus
+
+ if HAVE_LINUX
++if HAVE_VIDEODEV
+ B += dc1394_vloopback
++endif
+ if HAVE_XV
+ A += dc1394_multiview
+ endif