summaryrefslogtreecommitdiffstats
path: root/main/lighttpd/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/lighttpd/APKBUILD')
-rw-r--r--main/lighttpd/APKBUILD38
1 files changed, 35 insertions, 3 deletions
diff --git a/main/lighttpd/APKBUILD b/main/lighttpd/APKBUILD
index aa178e2bb..49e73ce99 100644
--- a/main/lighttpd/APKBUILD
+++ b/main/lighttpd/APKBUILD
@@ -1,14 +1,17 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=lighttpd
pkgver=1.4.25
-pkgrel=0
+_streamver=2.2.0
+pkgrel=2
pkgdesc="a secure, fast, compliant and very flexible web-server"
url="http://www.lighttpd.net/"
license="custom"
install="$pkgname.pre-install $pkgname.post-install"
depends=
-makedepends="flex pcre-dev openssl-dev zlib-dev bzip2-dev lua-dev pkgconfig"
+makedepends="flex pcre-dev openssl-dev zlib-dev bzip2-dev lua-dev pkgconfig
+ automake autoconf"
source="http://download.lighttpd.net/lighttpd/releases-1.4.x/$pkgname-$pkgver.tar.bz2
+ http://h264.code-shop.com/download/lighttpd-1.4.18_mod_h264_streaming-$_streamver.tar.gz
$pkgname.initd
$pkgname.confd
$pkgname.logrotate
@@ -19,7 +22,25 @@ source="http://download.lighttpd.net/lighttpd/releases-1.4.x/$pkgname-$pkgver.ta
mod_cgi.conf
mod_fastcgi.conf
"
-subpackages="$pkgname-dev $pkgname-doc"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-h264_streaming"
+
+prepare() {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ # copy over the mod-h264-streaming mod
+ # http://h264.code-shop.com/trac/wiki/Mod-H264-Streaming-Lighttpd-Version2#DownloadLighttpd1.4.191.4.20andother1.4.x
+ cp "$srcdir"/lighttpd-1.4.18/src/moov.* src/
+ cp "$srcdir"/lighttpd-1.4.18/src/mod_h264_streaming.c src/
+
+ cat >> src/Makefile.am <<__EOF__
+
+lib_LTLIBRARIES += mod_h264_streaming.la
+mod_h264_streaming_la_SOURCES = mod_h264_streaming.c moov.c
+mod_h264_streaming_la_LDFLAGS = -module -export-dynamic -avoid-version -no-undefined
+mod_h264_streaming_la_LIBADD = \$(common_libadd)
+__EOF__
+ aclocal -I m4 && autoconf && automake
+}
build() {
local i
@@ -70,7 +91,18 @@ package() {
install -m644 "$srcdir"/$i "$pkgdir"/etc/lighttpd/$i
done
}
+
+h264_streaming() {
+ pkgdesc="H264 Streaming Module for lighttpd"
+ url="http://h264.code-shop.com/trac"
+ license="CCPL-nc-sa-3.0"
+ mkdir -p "$subpkgdir"/usr/lib/lighttpd
+ mv "$pkgdir"/usr/lib/lighttpd/mod_h264_streaming.so \
+ "$subpkgdir"/usr/lib/lighttpd/
+}
+
md5sums="2027c49fb46530e45338c5e2da13c02f lighttpd-1.4.25.tar.bz2
+ac37885c881a058194405232e7737a7a lighttpd-1.4.18_mod_h264_streaming-2.2.0.tar.gz
36c4ddbc266017dc193fcb0cdd1d84e1 lighttpd.initd
0dede109282bfe685bdec6b35f0e4b6b lighttpd.confd
ad091c9157134890499f26d170352c9f lighttpd.logrotate