summaryrefslogtreecommitdiffstats
path: root/main/net-snmp
diff options
context:
space:
mode:
Diffstat (limited to 'main/net-snmp')
-rw-r--r--main/net-snmp/APKBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/main/net-snmp/APKBUILD b/main/net-snmp/APKBUILD
index 03da23fed..32d03e947 100644
--- a/main/net-snmp/APKBUILD
+++ b/main/net-snmp/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=net-snmp
pkgver=5.7.1
-pkgrel=5
+pkgrel=6
pkgdesc="Simple Network Management Protocol"
url="http://www.net-snmp.org/"
arch="all"
@@ -60,6 +60,7 @@ build() {
--enable-ucd-snmp-compatibility \
--with-persistent-directory="/var/lib/net-snmp" \
--with-openssl \
+ --enable-pic \
--enable-ipv6 \
--enable-shared \
--enable-as-needed \
@@ -68,8 +69,11 @@ build() {
# embedded-perl seems to create TEXTREL's
# work around parallell build issue
- make sedscript && make -j1 -C man || return 1
- make || return 1
+ make sedscript EXAMPLE.conf net-snmp-config-x \
+ && make -j1 -C man \
+ && make standardall \
+ && make net-snmp-create-v3-user \
+ && make || return 1
}
package() {