summaryrefslogtreecommitdiffstats
path: root/testing/py-dpath/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py-dpath/APKBUILD')
-rw-r--r--testing/py-dpath/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/testing/py-dpath/APKBUILD b/testing/py-dpath/APKBUILD
new file mode 100644
index 000000000..ba3a40b37
--- /dev/null
+++ b/testing/py-dpath/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-dpath
+_pkgname=dpath
+pkgver=1.2
+_pkgsver=45
+pkgrel=0._pkgver
+pkgdesc="Filesystem-like pathing and searching for dictionaries"
+url="https://www.github.com/akesterson/dpath-python"
+arch="noarch"
+license="MIT"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver-$_pkgsver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver-$_pkgsver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="79dcf705c2edddecdcfcbc4cac860313 dpath-1.2-45.tar.gz"
+sha256sums="4356d8d016392d11dba247070aae8eedadacb0511034d3df4f2c2c0202814fb0 dpath-1.2-45.tar.gz"
+sha512sums="242061d6c16c29bc3237b60194ec7e6267509218f8359f7a0ed1b88145712628413298de6ae219bbb46f20f292cb98275f67648e7df82f1673d46a8d4863b0da dpath-1.2-45.tar.gz"