summaryrefslogtreecommitdiffstats
path: root/testing/pylint
diff options
context:
space:
mode:
Diffstat (limited to 'testing/pylint')
-rw-r--r--testing/pylint/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/pylint/APKBUILD b/testing/pylint/APKBUILD
new file mode 100644
index 000000000..bb524faa5
--- /dev/null
+++ b/testing/pylint/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=pylint
+pkgver=0.23.0
+pkgrel=0
+pkgdesc="Analyzes Python code looking for bugs and signs of poor quality"
+url="http://pypi.python.org/pypi/pylint"
+arch="noarch"
+license="GPL2+"
+depends="python py-logilab-astng"
+depends_dev=""
+makedepends="python-dev py-logilab-astng"
+install=""
+subpackages="$pkgname-doc"
+source="http://pypi.python.org/packages/source/p/$pkgname/$pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+doc() {
+ # The man page is not picked-up automatically
+ mkdir -p "$subpkgdir"/usr/share/man/man1 || return 1
+ mv "$_builddir"/man/*.1 "$subpkgdir"/usr/share/man/man1/ || return 1
+}
+
+md5sums="f010eee3289b1af77cd8e8e45fb72829 pylint-0.23.0.tar.gz"