summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-03-17 09:45:49 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-03-17 09:47:05 +0000
commit3b27406f6446fa5a45aa181030a80dcf9a75ed6f (patch)
treecbc42dc1813ee881e214dd18617b87761ca3699d
parent0bc0559d6eca1981236fdab61dfed72fca61ac85 (diff)
downloadaports-3b27406f6446fa5a45aa181030a80dcf9a75ed6f.tar.bz2
aports-3b27406f6446fa5a45aa181030a80dcf9a75ed6f.tar.xz
testing/printproto: new aport
X11 print extension wire protocol http://xorg.freedesktop.org/
-rw-r--r--testing/printproto/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/printproto/APKBUILD b/testing/printproto/APKBUILD
new file mode 100644
index 000000000..dc1c0b415
--- /dev/null
+++ b/testing/printproto/APKBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=printproto
+pkgver=1.0.5
+pkgrel=0
+pkgdesc="X11 print extension wire protocol"
+url="http://xorg.freedesktop.org/"
+arch="noarch"
+license="custom"
+depends=""
+depends_dev="util-macros"
+makedepends="$depends_dev"
+source="http://xorg.freedesktop.org/releases/individual/proto/$pkgname-$pkgver.tar.bz2"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr
+ make || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install || return 1
+}
+md5sums="99d0e25feea2fead7d8325b7000b41c3 printproto-1.0.5.tar.bz2"