summaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-04-23 14:35:55 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-04-23 14:36:50 +0000
commit15d5070c984e5d206de86a34831ae25e396f7a3b (patch)
tree914d663f8f37bd4429c822b76856cc65399718f5 /main
parenta8865bca760dc6b1ac64b8bb8dacbf75e6d69847 (diff)
downloadaports-15d5070c984e5d206de86a34831ae25e396f7a3b.tar.bz2
aports-15d5070c984e5d206de86a34831ae25e396f7a3b.tar.xz
main/freeswitch: moved from testing
Diffstat (limited to 'main')
-rw-r--r--main/freeswitch/APKBUILD64
-rw-r--r--main/freeswitch/freeswitch.confd25
-rwxr-xr-xmain/freeswitch/freeswitch.initd33
-rwxr-xr-xmain/freeswitch/freeswitch.post-deinstall4
-rwxr-xr-xmain/freeswitch/freeswitch.post-install5
-rwxr-xr-xmain/freeswitch/freeswitch.pre-install4
-rw-r--r--main/freeswitch/modules.conf75
7 files changed, 210 insertions, 0 deletions
diff --git a/main/freeswitch/APKBUILD b/main/freeswitch/APKBUILD
new file mode 100644
index 000000000..4659f4f51
--- /dev/null
+++ b/main/freeswitch/APKBUILD
@@ -0,0 +1,64 @@
+# Contributor: Michael Mason <ms13sp@gmail.com>
+pkgname=freeswitch
+pkgver=1.0.6
+pkgrel=1
+pkgdesc="A communications platform written in C from the ground up"
+url="http://www.freeswitch.org"
+license="GPL"
+depends=""
+makedepends="curl-dev unixodbc-dev zlib-dev openssl-dev
+ autoconf automake libtool"
+install=
+subpackages="$pkgname-dev"
+source="http://files.freeswitch.org/freeswitch-$pkgver.tar.gz
+ modules.conf
+ freeswitch.confd
+ freeswitch.initd
+ freeswitch.post-install
+ freeswitch.pre-install
+ freeswitch.post-deinstall
+ "
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ cp -f "$srcdir/modules.conf" modules.conf || return 1
+
+ # i think our max cmd len is 32768
+ # by specifying it here we save our selves from some CPU cycles
+ export lt_cv_sys_max_cmd_len=8192
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc/freeswitch \
+ --with-modinstdir=/usr/lib/freeswitch \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+
+ # check how/when parallel builds are fixed here:
+ # http://jira.freeswitch.org/browse/FSBUILD-6
+
+ # build the libs and prerequisites in parallel first
+ make libs/apr/libapr-1.la \
+ libs/apr-util/libaprutil-1.la \
+ libs/speex/libspeex/libspeexdsp.la \
+ libs/sqlite/libsqlite3.la \
+ libs/pcre/libpcre.la \
+ libs/srtp/libsrtp.la \
+ src/include/switch_version.h
+
+ # then the rest should build in parallel too
+ make || return 1
+}
+package(){
+ cd "$srcdir/$pkgname-$pkgver"
+ make -j1 DESTDIR="$pkgdir" install
+ install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+md5sums="388effee587887a81fe7f411b7350590 freeswitch-1.0.6.tar.gz
+c05f2356be159e99b3845f5260a33599 modules.conf
+c608cca8ad773acebf201f581438c7e7 freeswitch.confd
+dd3a6535c54fc6ed8399d6bb57d88369 freeswitch.initd
+c0d7ad55063b1f62c9a2fcfa37b2fc0a freeswitch.post-install
+a34305ba1f8a8e7e6dbb9c678cc442b9 freeswitch.pre-install
+a7188703019a74fd7f128d165b3ecf42 freeswitch.post-deinstall"
diff --git a/main/freeswitch/freeswitch.confd b/main/freeswitch/freeswitch.confd
new file mode 100644
index 000000000..378e4b41f
--- /dev/null
+++ b/main/freeswitch/freeswitch.confd
@@ -0,0 +1,25 @@
+#
+# FreeSWITCH startup configuration
+#
+
+# freeswitch will be running with this userid
+FREESWITCH_USER="freeswitch"
+
+
+# optional: group the freeswitch process should be running with
+#
+# (note: without this option freeswitch will be using all groups
+# the user in FREESWITCH_USER is a member of)
+#
+#FREESWITCH_GROUP="freeswitch"
+
+
+
+# optional: other options, e.g.
+#
+# -hp Use realtime priority and protect freeswitch
+# process from being swapped to disk
+# (warning: dangerous on machines with little ram!)
+#
+#FREESWITCH_OPTS=""
+
diff --git a/main/freeswitch/freeswitch.initd b/main/freeswitch/freeswitch.initd
new file mode 100755
index 000000000..84381d771
--- /dev/null
+++ b/main/freeswitch/freeswitch.initd
@@ -0,0 +1,33 @@
+#!/sbin/runscript
+# Copyright 2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: $
+
+depend() {
+ need net
+}
+
+start() {
+ local OPTS
+
+ [ -n "${FREESWITCH_USER}" ] && \
+ OPTS="${OPTS} -u ${FREESWITCH_USER}"
+
+ [ -n "${FREESWITCH_GROUP}" ] && \
+ OPTS="${OPTS} -g ${FREESWITCH_GROUP}"
+
+ [ -n "${FREESWITCH_OPTS}" ] && \
+ OPTS="${OPTS} ${FREESWITCH_OPTS}"
+
+ ebegin "Starting Freeswitch"
+ start-stop-daemon --start --quiet --exec /usr/bin/freeswitch \
+ --pidfile /var/run/freeswitch.pid -- -nc ${OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Freeswitch"
+ start-stop-daemon --stop --quiet --pidfile /var/run/freeswitch.pid
+ eend $?
+}
+
diff --git a/main/freeswitch/freeswitch.post-deinstall b/main/freeswitch/freeswitch.post-deinstall
new file mode 100755
index 000000000..5ec871cb1
--- /dev/null
+++ b/main/freeswitch/freeswitch.post-deinstall
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+deluser freeswitch
+delgroup freeswitch
diff --git a/main/freeswitch/freeswitch.post-install b/main/freeswitch/freeswitch.post-install
new file mode 100755
index 000000000..3b1c414c6
--- /dev/null
+++ b/main/freeswitch/freeswitch.post-install
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+chown -R freeswitch:freeswitch /etc/freeswitch/
+chown -R freeswitch:freeswitch /var/run/freeswitch/
+
diff --git a/main/freeswitch/freeswitch.pre-install b/main/freeswitch/freeswitch.pre-install
new file mode 100755
index 000000000..b8065b52b
--- /dev/null
+++ b/main/freeswitch/freeswitch.pre-install
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+adduser -h /dev/null -s /bin/false -D freeswitch 2>/dev/null
+mkdir /var/run/freeswitch
diff --git a/main/freeswitch/modules.conf b/main/freeswitch/modules.conf
new file mode 100644
index 000000000..c6f5a05de
--- /dev/null
+++ b/main/freeswitch/modules.conf
@@ -0,0 +1,75 @@
+loggers/mod_console
+loggers/mod_logfile
+loggers/mod_syslog
+applications/mod_commands
+applications/mod_conference
+applications/mod_dptools
+applications/mod_enum
+applications/mod_fifo
+#applications/mod_fax
+applications/mod_voicemail
+#applications/mod_lcr
+applications/mod_limit
+applications/mod_expr
+applications/mod_esf
+#applications/mod_easyroute
+applications/mod_fsv
+#applications/mod_soundtouch
+#applications/mod_rss
+#applications/mod_snom
+#applications/mod_vmd
+#asr_tts/mod_flite
+#asr_tts/mod_pocketsphinx
+#asr_tts/mod_cepstral
+codecs/mod_g723_1
+codecs/mod_amr
+#codecs/mod_amrwb
+codecs/mod_g729
+codecs/mod_h26x
+codecs/mod_voipcodecs
+codecs/mod_ilbc
+codecs/mod_speex
+#codecs/mod_siren
+#codecs/mod_celt
+#codecs/mod_dahdi_codec
+#dialplans/mod_dialplan_directory
+dialplans/mod_dialplan_xml
+dialplans/mod_dialplan_asterisk
+#directories/mod_ldap
+#endpoints/mod_dingaling
+endpoints/mod_iax
+#endpoints/mod_portaudio
+endpoints/mod_sofia
+endpoints/mod_loopback
+#endpoints/mod_alsa
+#endpoints/mod_opal
+#../../libs/openzap/mod_openzap
+#event_handlers/mod_event_multicast
+event_handlers/mod_event_socket
+event_handlers/mod_cdr_csv
+#event_handlers/mod_radius_cdr
+formats/mod_native_file
+formats/mod_sndfile
+#formats/mod_shout
+formats/mod_local_stream
+formats/mod_tone_stream
+#languages/mod_python
+#languages/mod_spidermonkey
+#languages/mod_spidermonkey_teletone
+#languages/mod_spidermonkey_core_db
+#languages/mod_spidermonkey_socket
+#languages/mod_spidermonkey_odbc
+languages/mod_lua
+#languages/mod_perl
+#languages/mod_yaml
+#xml_int/mod_xml_rpc
+#xml_int/mod_xml_curl
+#xml_int/mod_xml_cdr
+#xml_int/mod_xml_ldap
+say/mod_say_en
+#say/mod_say_de
+#say/mod_say_es
+#say/mod_say_fr
+#say/mod_say_it
+#say/mod_say_nl
+#say/mod_say_zh