summaryrefslogtreecommitdiffstats
path: root/testing/libsyncml/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2010-09-26 19:27:33 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2010-09-26 19:27:33 +0000
commit30e8feac61c3c7cc7e84159c29b00f5e49dbedef (patch)
tree26de2e814714096f0ae86a7846ec8e5b82be5db7 /testing/libsyncml/APKBUILD
parent6267ff5c95ad547b5698bb2fe38a51475ad61da8 (diff)
parente59f25e6a0d9d18f07ee5b249c535edfbfdb832e (diff)
downloadaports-eglibc.tar.bz2
aports-eglibc.tar.xz
Merge branch 'master' into eglibceglibc
Diffstat (limited to 'testing/libsyncml/APKBUILD')
-rw-r--r--testing/libsyncml/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/libsyncml/APKBUILD b/testing/libsyncml/APKBUILD
new file mode 100644
index 000000000..0d8617113
--- /dev/null
+++ b/testing/libsyncml/APKBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libsyncml
+pkgver=0.5.4
+pkgrel=0
+pkgdesc="Implementation of the SyncML protocol"
+url="http://libsyncml.opensync.org/"
+license="LGPL-2.1"
+depends=
+makedepends="glib-dev libxml2-dev libwbxml-dev openobex-dev bluez-dev cmake"
+install=
+subpackages="$pkgname-dev"
+source="http://downloads.sourceforge.net/libsyncml/libsyncml-$pkgver.tar.bz2"
+
+_srcdir="$srcdir"/$pkgname-$pkgver
+_builddir="$srcdir"/build
+
+prepare() {
+ mkdir -p "$_builddir"
+}
+
+build() {
+ cd "$_builddir"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr "$_srcdir"
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make install DESTDIR="$pkgdir"
+}
+
+md5sums="b8ce1f222cccc12acdcd6807d65c1aea libsyncml-0.5.4.tar.bz2"