summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-11-26 22:38:48 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-11-26 22:40:56 +0000
commit73d97efe30652dc2931b985e9bcbd46ce0e955f2 (patch)
tree4e54a0c405880ecd4434a26825069f4bf5116a7a /testing
parentc9bc946cb076ee2e42500cf9a6a427da823339a0 (diff)
downloadaports-73d97efe30652dc2931b985e9bcbd46ce0e955f2.tar.bz2
aports-73d97efe30652dc2931b985e9bcbd46ce0e955f2.tar.xz
testing/qt: upgrade to 4.7.1
Diffstat (limited to 'testing')
-rw-r--r--testing/qt/APKBUILD11
-rw-r--r--testing/qt/fix-multisampling-with-ati-card.patch25
-rw-r--r--testing/qt/fix-scroll-when-last-item-is-removed.patch38
3 files changed, 4 insertions, 70 deletions
diff --git a/testing/qt/APKBUILD b/testing/qt/APKBUILD
index 3fa4136c2..c87a1957e 100644
--- a/testing/qt/APKBUILD
+++ b/testing/qt/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=qt
-pkgver=4.7.0
+pkgver=4.7.1
pkgrel=0
pkgdesc="A cross-platform application and UI framework"
url="http://qt.nokia.com/"
@@ -16,8 +16,7 @@ source="ftp://ftp.qt.nokia.com/qt/source/qt-everywhere-opensource-src-$pkgver.ta
designer.desktop
linguist.desktop
qtconfig.desktop
- fix-scroll-when-last-item-is-removed.patch
- fix-multisampling-with-ati-card.patch"
+ "
_builddir="$srcdir"/qt-everywhere-opensource-src-$pkgver
prepare() {
@@ -113,10 +112,8 @@ package() {
-exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d;s/\(QMAKE_PRL_LIBS =\).*/\1/' {} \;
}
-md5sums="3a2f25b9b115037277f4fb759194a7a5 qt-everywhere-opensource-src-4.7.0.tar.gz
+md5sums="6f88d96507c84e9fea5bf3a71ebeb6d7 qt-everywhere-opensource-src-4.7.1.tar.gz
a445c6917086d80f1cfc1e40cb6b0132 assistant.desktop
d457f0a0ad68a3861c3cadefe3b42ded designer.desktop
668331d9798a0e2b94381efb7be4c513 linguist.desktop
-c29f2993d6a0f73d756d2fa36e130e1c qtconfig.desktop
-ef20c34afc5be5ed62f2935be66d9402 fix-scroll-when-last-item-is-removed.patch
-b2e0f134bbb848ebef41134a45a36ee9 fix-multisampling-with-ati-card.patch"
+c29f2993d6a0f73d756d2fa36e130e1c qtconfig.desktop"
diff --git a/testing/qt/fix-multisampling-with-ati-card.patch b/testing/qt/fix-multisampling-with-ati-card.patch
deleted file mode 100644
index c215c2cc1..000000000
--- a/testing/qt/fix-multisampling-with-ati-card.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From e48e50c460434c451c67403390d98f7418c77cce Mon Sep 17 00:00:00 2001
-From: Jonathan Liu <net147@gmail.com>
-Date: Wed, 25 Aug 2010 14:07:40 +1000
-Subject: [PATCH] Fix OpenGL multisampling for some graphics drivers
-
----
- src/opengl/qgl_win.cpp | 2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
-
-diff --git a/src/opengl/qgl_win.cpp b/src/opengl/qgl_win.cpp
-index 5ab944a..8eb6177 100644
---- a/src/opengl/qgl_win.cpp
-+++ b/src/opengl/qgl_win.cpp
-@@ -1042,7 +1042,7 @@ int QGLContext::choosePixelFormat(void* dummyPfd, HDC pdc)
- iAttributes[i++] = WGL_DRAW_TO_WINDOW_ARB;
- iAttributes[i++] = TRUE;
- iAttributes[i++] = WGL_COLOR_BITS_ARB;
-- iAttributes[i++] = 32;
-+ iAttributes[i++] = 24;
- iAttributes[i++] = WGL_DOUBLE_BUFFER_ARB;
- iAttributes[i++] = d->glFormat.doubleBuffer();
- if (d->glFormat.stereo()) {
---
-1.7.2.1
-
diff --git a/testing/qt/fix-scroll-when-last-item-is-removed.patch b/testing/qt/fix-scroll-when-last-item-is-removed.patch
deleted file mode 100644
index 86567024f..000000000
--- a/testing/qt/fix-scroll-when-last-item-is-removed.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From 6da6b7099d4e0b49329793e4b90703ec3d868048 Mon Sep 17 00:00:00 2001
-From: Frank Reininghaus <frank78ac@googlemail.com>
-Date: Wed, 22 Sep 2010 10:19:59 +0200
-Subject: [PATCH] QTreeView: do not scroll to top if last item is removed
-
-When the last item is the current item and is removed,
-QTreeViewPrivate::updateScrollBars() is called after QTreeViewPrivate's
-viewItems member is cleared. This commit makes sure that viewItems is
-restored by calling QTreeView::doItemsLayout() in this case, preventing
-that the scroll bar range is set to zero temporarily and the view is
-scrolled to the top unexpectedly (this was a regression in 4.7.0:
-QTBUG-13567).
-
-Merge-request: 2481
-Reviewed-by: Olivier Goffart <olivier.goffart@nokia.com>
----
- src/gui/itemviews/qtreeview.cpp | 4 ++++
- tests/auto/qtreeview/tst_qtreeview.cpp | 22 ++++++++++++++++++++++
- 2 files changed, 26 insertions(+), 0 deletions(-)
-
-diff --git a/src/gui/itemviews/qtreeview.cpp b/src/gui/itemviews/qtreeview.cpp
-index b797776..40b51fe 100644
---- a/src/gui/itemviews/qtreeview.cpp
-+++ b/src/gui/itemviews/qtreeview.cpp
-@@ -3435,6 +3435,10 @@ void QTreeViewPrivate::updateScrollBars()
- if (!viewportSize.isValid())
- viewportSize = QSize(0, 0);
-
-+ if (viewItems.isEmpty()) {
-+ q->doItemsLayout();
-+ }
-+
- int itemsInViewport = 0;
- if (uniformRowHeights) {
- if (defaultItemHeight <= 0)
---
-1.6.1
-