summaryrefslogtreecommitdiffstats
path: root/main/hunspell
diff options
context:
space:
mode:
Diffstat (limited to 'main/hunspell')
-rw-r--r--main/hunspell/APKBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/main/hunspell/APKBUILD b/main/hunspell/APKBUILD
index 6883855ae..baf7876c2 100644
--- a/main/hunspell/APKBUILD
+++ b/main/hunspell/APKBUILD
@@ -6,17 +6,19 @@ pkgdesc="Spell checker and morphological analyzer library and program"
url="http://hunspell.sourceforge.net/"
license="GPL LGPL MPL"
subpackages="$pkgname-dev $pkgname-doc"
-depends="libgcc uclibc++"
-makedepends="uclibc++-dev"
+depends=
+makedepends=
source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
build ()
{
cd "$srcdir/hunspell-$pkgver"
- export CXX="${CXX_UC:-g++-uc}"
-
./configure --prefix=/usr --disable-static || return 1
make || return 1
+}
+
+package() {
+ cd "$srcdir/hunspell-$pkgver"
make DESTDIR="$pkgdir" install || return 1
rm -rf "$pkgdir"/usr/share/locale/locale.alias
}