summaryrefslogtreecommitdiffstats
path: root/aports.lua
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-08-24 20:15:53 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2011-08-24 20:15:53 +0200
commit85b54b355e416ccce6b34866bb3d7a5fa8f2bb5a (patch)
tree6c5a3647c9c6dba6d90c4a08941a97904344b239 /aports.lua
parentfda6873c5a1c92363685d5dcc319d8e776a8f692 (diff)
downloadabuild-85b54b355e416ccce6b34866bb3d7a5fa8f2bb5a.tar.bz2
abuild-85b54b355e416ccce6b34866bb3d7a5fa8f2bb5a.tar.xz
aports.lua: implement get_maintainer()
So we can fish out the maintainer from given aport
Diffstat (limited to 'aports.lua')
-rwxr-xr-xaports.lua20
1 files changed, 20 insertions, 0 deletions
diff --git a/aports.lua b/aports.lua
index 3f7e9ae..e513a61 100755
--- a/aports.lua
+++ b/aports.lua
@@ -121,6 +121,26 @@ function foreach_remote_source(p, func)
end
end
+function get_maintainer(pkg)
+ if pkg == nil or pkg.dir == nil then
+ return nil
+ end
+ local f = io.open(pkg.dir.."/APKBUILD")
+ if f == nil then
+ return nil
+ end
+ local line
+ for line in f:lines() do
+ local maintainer = line:match("^%s*#%s*Maintainer:%s*(.*)")
+ if maintainer then
+ f:close()
+ return maintainer
+ end
+ end
+ f:close()
+ return nil
+end
+
local function init_apkdb(repodirs)
local pkgdb = {}
local revdeps = {}