aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-02-25 12:22:24 +0100
committerCarlo Landmeter <clandmeter@gmail.com>2016-02-25 12:22:29 +0100
commit521e491695c4ce430cdf03f66d2c2c80e3e39d1c (patch)
treea7c2b7ad8eb005290f02cacc5ff3f22b5c8055f5
parentdacff0b394eb656de164164cd80eb8711291961b (diff)
downloadaports-521e491695c4ce430cdf03f66d2c2c80e3e39d1c.tar.bz2
aports-521e491695c4ce430cdf03f66d2c2c80e3e39d1c.tar.xz
community/libhdhomerun: fix srcdir cosmetics and move to community
-rw-r--r--community/libhdhomerun/APKBUILD (renamed from testing/libhdhomerun/APKBUILD)44
1 files changed, 25 insertions, 19 deletions
diff --git a/testing/libhdhomerun/APKBUILD b/community/libhdhomerun/APKBUILD
index 99c596be5..3edb77497 100644
--- a/testing/libhdhomerun/APKBUILD
+++ b/community/libhdhomerun/APKBUILD
@@ -11,34 +11,40 @@ depends=""
depends_dev=""
makedepends="$depends_dev"
install=""
-subpackages="$pkgname-dev $pkgname-doc"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-config"
source="http://download.silicondust.com/hdhomerun/${pkgname}_${pkgver}.tgz"
-_builddir=
+_builddir="$srcdir/$pkgname"
+
prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
}
build() {
- cd "$_builddir"
- cd libhdhomerun
- make || return 1
+ cd "$_builddir"
+ make || return 1
}
package() {
- cd "$_builddir"
- cd src/libhdhomerun
- install -Dm755 hdhomerun_config "$pkgdir"/usr/bin/hdhomerun_config
- install -Dm444 libhdhomerun.so "$pkgdir"/usr/lib/libhdhomerun.so
- install -d "$pkgdir"/usr/include/libhdhomerun
- install -D *.h "$pkgdir"/usr/include/libhdhomerun
- install -Dm644 lgpl.txt "$pkgdir"/usr/share/licenses/$pkgname/lgpl.txt
+ cd "$_builddir"
+ install -Dm444 libhdhomerun.so \
+ "$pkgdir"/usr/lib/libhdhomerun.so || return 1
+ install -D *.h "$pkgdir"/usr/include/libhdhomerun || return 1
+ install -Dm644 lgpl.txt \
+ "$pkgdir"/usr/share/licenses/$pkgname/lgpl.txt || return 1
+}
+
+config() {
+ pkgdesc="$pkgname config utility"
+ cd "$_builddir"
+ install -Dm755 hdhomerun_config \
+ "$subpkgdir"/usr/bin/hdhomerun_config || return 1
}
md5sums="05f9a9e1fc8f6ec004b399034775cab0 libhdhomerun_20150826.tgz"