aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-01-12 15:53:25 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-01-12 15:59:52 +0000
commit5dcfde2881184a0aec6327c6f79fa73e84020a6f (patch)
treef562fef89303afc28295196f79871e71e3c7814d
parentf797e806de7925e20e640094394fc6151b4b1c99 (diff)
downloadaports-5dcfde2881184a0aec6327c6f79fa73e84020a6f.tar.bz2
aports-5dcfde2881184a0aec6327c6f79fa73e84020a6f.tar.xz
testing/json-glib: new aport
JSON library built on GLib http://live.gnome.org/JsonGlib
-rw-r--r--testing/json-glib/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/json-glib/APKBUILD b/testing/json-glib/APKBUILD
new file mode 100644
index 000000000..c0aed8223
--- /dev/null
+++ b/testing/json-glib/APKBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=json-glib
+pkgver=0.12.2
+pkgrel=0
+pkgdesc="JSON library built on GLib"
+arch="all"
+url="http://live.gnome.org/JsonGlib"
+license="GPL"
+depends=""
+makedepends="gobject-introspection glib-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://ftp.gnome.org/pub/GNOME/sources/json-glib/0.12/json-glib-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="71f911329c9f742543b378c3494490da json-glib-0.12.2.tar.bz2"