aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2011-06-02 11:36:28 +0300
committerTimo Teräs <timo.teras@iki.fi>2011-06-02 11:48:26 +0300
commit6f2ceb5df28f9bafcab200b9615c54909125292f (patch)
tree7da58275b8e7dc826170e564ebf208927ec6b11f
parent2f174a00cfa468e8a80cf1a7f2585aa7d946da61 (diff)
downloadaports-6f2ceb5df28f9bafcab200b9615c54909125292f.tar.bz2
aports-6f2ceb5df28f9bafcab200b9615c54909125292f.tar.xz
testing/perl-cgi-psgi: new apkbuild-cpan generated aport
Adapt CGI.pm to the PSGI protocol http://search.cpan.org/dist/CGI-PSGI/
-rw-r--r--testing/perl-cgi-psgi/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/perl-cgi-psgi/APKBUILD b/testing/perl-cgi-psgi/APKBUILD
new file mode 100644
index 000000000..d00f1c18d
--- /dev/null
+++ b/testing/perl-cgi-psgi/APKBUILD
@@ -0,0 +1,37 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=perl-cgi-psgi
+_pkgreal=CGI-PSGI
+pkgver=0.15
+pkgrel=0
+pkgdesc="Adapt CGI.pm to the PSGI protocol"
+url="http://search.cpan.org/dist/CGI-PSGI/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends=""
+cpanmakedepends=""
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/M/MI/MIYAGAWA/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$_builddir"
+ make && make test
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="58a39711add2b48229710688c5f81cfd CGI-PSGI-0.15.tar.gz"