aboutsummaryrefslogtreecommitdiffstats
path: root/community/hub
diff options
context:
space:
mode:
authorEivind Uggedal <eivind@uggedal.com>2015-09-30 08:30:44 +0000
committerEivind Uggedal <eivind@uggedal.com>2015-09-30 08:30:44 +0000
commit675a55b3a13ee4daef9e7a10f9ff9ae3c640e4d0 (patch)
tree34ad098accbf9ee78e5404a0f51181e97f1bf5d6 /community/hub
parente70d1cb0d423023d43220acf421edfc6235446ed (diff)
downloadaports-675a55b3a13ee4daef9e7a10f9ff9ae3c640e4d0.tar.bz2
aports-675a55b3a13ee4daef9e7a10f9ff9ae3c640e4d0.tar.xz
community/hub: moved from main
Diffstat (limited to 'community/hub')
-rw-r--r--community/hub/APKBUILD57
1 files changed, 57 insertions, 0 deletions
diff --git a/community/hub/APKBUILD b/community/hub/APKBUILD
new file mode 100644
index 000000000..5e73409f4
--- /dev/null
+++ b/community/hub/APKBUILD
@@ -0,0 +1,57 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Contributor: Eivind Uggedal <eivind@uggedal.com>
+# Maintainer
+pkgname=hub
+pkgver=2.2.1
+pkgrel=1
+pkgdesc="Extends git with extra features for GitHub"
+url="http://hub.github.com/"
+arch="all"
+license="MIT"
+depends=""
+makedepends="go bash"
+install=""
+options="!strip"
+subpackages="
+ $pkgname-doc
+ $pkgname-bash-completion:bashcomp
+ $pkgname-zsh-completion:zshcomp"
+source="$pkgname-$pkgver.tar.gz::https://github.com/github/hub/archive/v$pkgver.tar.gz"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+build() {
+ # XXX this sucks a lot, it simply sets up GOPATH
+ # and invokes go get afterwards thus we cannot
+ # verify the integrity of the downloaded packages.
+ cd "$_builddir" && ./script/build
+}
+
+package() {
+ cd "$_builddir"
+ install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
+ install -D -m644 man/$pkgname.1 "$pkgdir"/usr/share/man/man1/$pkgname.1
+}
+
+bashcomp() {
+ depends=""
+ pkgdesc="Bash completions for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
+ arch="noarch"
+
+ install -Dm644 "$_builddir"/etc/hub.bash_completion.sh \
+ "$subpkgdir"/usr/share/bash-completion/completions/$pkgname || return 1
+}
+
+zshcomp() {
+ depends=""
+ pkgdesc="Zsh completions for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel zsh"
+ arch="noarch"
+
+ install -Dm644 "$_builddir"/etc/$pkgname.zsh_completion \
+ "$subpkgdir"/usr/share/zsh/site-functions/_$pkgname || return 1
+}
+
+md5sums="889a31ee9d10ae9cb333480d8dbe881f hub-2.2.1.tar.gz"
+sha256sums="9350aba6a8e3da9d26b7258a4020bf84491af69595f7484f922d75fc8b86dc10 hub-2.2.1.tar.gz"
+sha512sums="8ccab0722903202a8aec28211c9560961948f3b9099f481809f1029d682fff0f88f65568c2fd03bfb9f7d66e0c148e232f801432c0bdd3840f4edf7e427679ac hub-2.2.1.tar.gz"