aboutsummaryrefslogtreecommitdiffstats
path: root/community/java-snappy
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-09-11 13:21:47 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-09-11 13:30:23 +0200
commita12d28f73d7d96ec9e1c7d5aafd6cf561478fb11 (patch)
tree1ef435544a32e0b8d0026232747925184a3cc2cc /community/java-snappy
parentc3fdec2a1701b2b8c1e3a97feb7d8f71fc5b9287 (diff)
downloadaports-a12d28f73d7d96ec9e1c7d5aafd6cf561478fb11.tar.bz2
aports-a12d28f73d7d96ec9e1c7d5aafd6cf561478fb11.tar.xz
community/java-snappy: reduce sbt's memory requirements
And also download build dependencies into $builddir instead of /tmp.
Diffstat (limited to 'community/java-snappy')
-rw-r--r--community/java-snappy/APKBUILD8
1 files changed, 3 insertions, 5 deletions
diff --git a/community/java-snappy/APKBUILD b/community/java-snappy/APKBUILD
index 63a5a87b4..7320ca9ad 100644
--- a/community/java-snappy/APKBUILD
+++ b/community/java-snappy/APKBUILD
@@ -35,13 +35,11 @@ prepare() {
build() {
cd "$builddir"
- JAVA_HOME=/usr/lib/jvm/default-jvm \
- make || return 1
+ JAVA_HOME="/usr/lib/jvm/default-jvm" make || return 1
msg "Downloading SBT and then building JAR (this will take few minutes)..."
- ./sbt -Dsbt.boot.directory=/tmp/sbt/boot \
- -Dsbt.ivy.home=/tmp/sbt/.ivy2 \
- package
+ JVM_OPTS="-Xms256m -Xmx256m -Xss2m" \
+ ./sbt -no-share -sbt-launch-dir project/.sbt/launchers package
}
package() {