aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-spiffy
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-19 08:52:10 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-19 11:24:36 +0000
commit11c0688f3e052343d57deffb666ab66f7ede97ae (patch)
tree543e746501e8ea908b21ca4a49ff29c30abeb7a2 /community/perl-spiffy
parent88d34faa7723721a3cbe7901ec8253248d96dfdf (diff)
downloadaports-11c0688f3e052343d57deffb666ab66f7ede97ae.tar.bz2
aports-11c0688f3e052343d57deffb666ab66f7ede97ae.tar.xz
community/perl-spiffy: moved from testing
Diffstat (limited to 'community/perl-spiffy')
-rw-r--r--community/perl-spiffy/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/community/perl-spiffy/APKBUILD b/community/perl-spiffy/APKBUILD
new file mode 100644
index 000000000..7484c98bb
--- /dev/null
+++ b/community/perl-spiffy/APKBUILD
@@ -0,0 +1,42 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=perl-spiffy
+_pkgreal=Spiffy
+pkgver=0.46
+pkgrel=0
+pkgdesc="Spiffy Perl Interface Framework For You"
+url="http://search.cpan.org/dist/Spiffy/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends=""
+cpanmakedepends=" "
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/I/IN/INGY/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ default_prepare || return 1
+
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make && make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="2ec7007c111a6bc2775bb7c57673a24b Spiffy-0.46.tar.gz"
+sha256sums="8f58620a8420255c49b6c43c5ff5802bd25e4f09240c51e5bf2b022833d41da3 Spiffy-0.46.tar.gz"
+sha512sums="a1fb02bae4a6edab564c05af2f1b2caaf996d433ec054e07e75a53e88216c46cf14db87a2abdfc9c74f73791267f69129a86bfdaa77492f941104143ca7b8154 Spiffy-0.46.tar.gz"