aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-13 17:44:47 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-13 17:44:47 +0000
commit440f0b39bdabf98c557aaede2f0bacec16f0fbe8 (patch)
treeefebef83dbcde281ffcda1287fa1b37e12c2106f /community
parentac50c09a44e0f895de173b0e0475d8a68fb34d6b (diff)
downloadaports-440f0b39bdabf98c557aaede2f0bacec16f0fbe8.tar.bz2
aports-440f0b39bdabf98c557aaede2f0bacec16f0fbe8.tar.xz
main/obnam: move to community
Diffstat (limited to 'community')
-rw-r--r--community/obnam/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/obnam/APKBUILD b/community/obnam/APKBUILD
new file mode 100644
index 000000000..64c2b70d0
--- /dev/null
+++ b/community/obnam/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: Eivind Uggedal <eivind@uggedal.com>
+pkgname=obnam
+pkgver=1.18.2
+pkgrel=0
+pkgdesc="A backup program that supports encryption and deduplication"
+url="http://obnam.org/"
+arch="all"
+license="GPL3+"
+depends="python py-larch py-paramiko py-fuse"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages="$pkgname-doc"
+source="http://code.liw.fi/debian/pool/main/o/$pkgname/${pkgname}_$pkgver.orig.tar.xz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="68b9a3e7a69f5f4fdb36e598c8f23407 obnam_1.18.2.orig.tar.xz"
+sha256sums="cb5ebfb8d7d71a203e26b49c920cd8e017018d3df44ead454f095b7a4e93b7a0 obnam_1.18.2.orig.tar.xz"
+sha512sums="3c1051027db329af40ff153a525f2652785d9e4e149d9804c88bce448c7b9efd7b2e53dd146f72f9e71a13a0932f2344be8dd313b7f387646162abecce568446 obnam_1.18.2.orig.tar.xz"