aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-10-27 00:59:19 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-10-27 01:00:15 +0200
commit475b098ea3cbd303c1653776ff9b6cce2b97fd8d (patch)
treef9600b6b045122fb7671420602495c6ebab62ba5 /community
parent39b6f4f1990af8caa859d7fbaf3b3e0e382b4f2b (diff)
downloadaports-475b098ea3cbd303c1653776ff9b6cce2b97fd8d.tar.bz2
aports-475b098ea3cbd303c1653776ff9b6cce2b97fd8d.tar.xz
community/libvterm: move from testing and claim maitainership
Diffstat (limited to 'community')
-rw-r--r--community/libvterm/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/community/libvterm/APKBUILD b/community/libvterm/APKBUILD
new file mode 100644
index 000000000..0d009eb62
--- /dev/null
+++ b/community/libvterm/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Daniel Sabogal <dsabogalcc@gmail.com>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=libvterm
+pkgver=0.0.20161007
+_gitref=e0a3d4dbd44a9534bf7437ee98ceb26dabebf3ad
+pkgrel=0
+pkgdesc="Abstract library implementation of a VT220/xterm/ECMA-48 terminal emulator"
+url="https://www.leonerd.org.uk/code/libvterm"
+arch="all"
+license="MIT"
+depends=""
+makedepends="libtool perl"
+subpackages="$pkgname-dev"
+source="https://github.com/neovim/$pkgname/archive/$_gitref.tar.gz"
+builddir="$srcdir/$pkgname-$_gitref"
+
+build() {
+ cd "$builddir"
+ make PREFIX=/usr
+}
+
+package() {
+ cd "$builddir"
+ make PREFIX=/usr DESTDIR="$pkgdir/" install
+}
+
+md5sums="078e30eadf5bda9d73a8d30627db99f6 e0a3d4dbd44a9534bf7437ee98ceb26dabebf3ad.tar.gz"
+sha256sums="1412f7a82924adc756dff51edeb0eda6749ff9e49cdbb11a4daae292380a7961 e0a3d4dbd44a9534bf7437ee98ceb26dabebf3ad.tar.gz"
+sha512sums="8ac8e442783a2db129087ea42e02034f4a7aa9070c5776f43879f5675b3da447e7f6fbd50a77713f0e424f1e0eb2ce203f9ee9e77999b0e208b033e37b4b6587 e0a3d4dbd44a9534bf7437ee98ceb26dabebf3ad.tar.gz"